Bug 174013 - Can't add LVM logical volumes in GRUB boot loader configuration in anaconda
Can't add LVM logical volumes in GRUB boot loader configuration in anaconda
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-23 12:23 EST by Ed Anderson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 22:39:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Anderson 2005-11-23 12:23:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.7.12) Gecko/20051015 Firefox/1.0.7

Description of problem:
When using LVM on a dual-boot system, you should be able to add operating systems that exist in logical volumes.  When Fedora's / partition exists on a logical volume, it automatically adds fedora's logical volume (similar to /dev/VolGroup00/LogVol00), but doesn't allow you to add any others.  When clicking Add in the boot loader screen, only devices such as /dev/hda1 and /dev/hda2 are listed as options.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start the Fedora installation
2. In Disk Druid, create a /boot and an LVM partition (logical group).
3. Edit the LVM partition, and add two logical volumes, / and /mnt/otherOS
4. Click Next to go to the boot loader screen
5. Click Add, and open the Device dropdown menu
  

Actual Results:  Logical volumes are not listed under devices. Only devices such as /dev/hda1 and /dev/hda2 are.

Expected Results:  LVM logical volumes should be listed in the Device dropdown.

Additional info:
Comment 1 Jeremy Katz 2005-11-24 22:39:12 EST
GRUB doesn't support logical volumes, so you can't chain load from other logical
volumes.
Comment 2 Ed Anderson 2005-11-27 10:53:50 EST
I understand that grub doesn't support /boot in a logical volume. Chain loading
isn't the issue.

GRUB does support loading an operating system from a logical volume.  Were this
not the case, you wouldn't be able to install Fedora's / partition in a logical
volume - which you can.  Like I said, if using LVM, the boot loader screen
automatically adds /dev/VolGroup00/LogVol00 as the default partition to boot
from.  The problem is that it doesn't allow you to add any logical / partitions
from other operating systems.

This is a bug. Please take a closer look at the issue.
Comment 3 Jeremy Katz 2005-11-27 13:09:28 EST
Right, but the difference is that for the system being installed, we're _not_
chainloading.  We have the full system config and know that /boot isn't LVM and
so load kernels, etc off of there.  Adding additional OS'es is just for
chainloading.

Note You need to log in before you can comment on or make changes to this bug.