Bug 174034 - anaconda crashes when file not found on mirror
anaconda crashes when file not found on mirror
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 174035 (view as bug list)
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-11-23 18:24 EST by Mary Ellen Foster
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-20 22:54:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt generated by anaconda (744.15 KB, text/plain)
2005-11-23 18:30 EST, Mary Ellen Foster
no flags Details

  None (edit)
Description Mary Ellen Foster 2005-11-23 18:24:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.0 (like Gecko) Kubuntu 6.04 Dapper

Description of problem:
This is probably not unexpected ... I just tried an HTTP install of FC5T1 from 
mirrorservice.org, and it seems to have an incomplete set of RPMs. So I went 
through the whole configuration process, and then when it started to download 
things I it didn't find libXext and exited. 
 
I can't see that this can be much better ... but at least it should fail in a 
less scary way. I'll attach the "anacdump.txt" file that I copied to my other 
laptop (cool feature!). 

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Try to do a network install of FC5T1 using an incompletely synchronised 
mirror.   

Additional info:
Comment 1 Mary Ellen Foster 2005-11-23 18:27:44 EST
*** Bug 174035 has been marked as a duplicate of this bug. ***
Comment 2 Mary Ellen Foster 2005-11-23 18:30:46 EST
Created attachment 121422 [details]
anacdump.txt generated by anaconda
Comment 3 Jeremy Katz 2005-11-24 22:07:00 EST
Yeah, handling of package download errors is currently very poor.  On the list
to be sure is fixed before release
Comment 4 Jeremy Katz 2006-01-20 22:54:05 EST
This should be handled properly now

Note You need to log in before you can comment on or make changes to this bug.