Bug 1740357 - Auth operator reporting unavailable and reason "available"
Summary: Auth operator reporting unavailable and reason "available"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: apiserver-auth
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.0
Assignee: Stefan Schimanski
QA Contact: scheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-12 18:13 UTC by Ben Parees
Modified: 2020-01-23 11:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: auth-operator reported a static "available" string as a reason for the unavailability condition. Consequence: the reason of unavailability of the operator was unclear. Fix: more precise reasons are implemented. Result: the reason describes why the operator reported unavailability.
Clone Of:
Environment:
Last Closed: 2020-01-23 11:05:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:05:32 UTC

Description Ben Parees 2019-08-12 18:13:29 UTC
Description of problem:
16 clusters in telemeter are reporting the auth operator as unavailable and with a reason of "available"

Version-Release number of selected component (if applicable):
Doesn't seem to be a way to drill into the specific clusters in telemter

How reproducible:
Always?

Actual results:
operator is unavailable and reason is not useful


Expected results:
operator should be available, and if it's not, the reason should indicate why


Additional info:
There are two asks here:

1) determine why the operator is unavailable in those 16 clusters
2) fix the reason reporting

Comment 2 Michal Fojtik 2019-08-21 14:07:39 UTC
I was not able to find the code that does this in the current version of auth operator, so I assume this is fixed in the latest version.
This is part of the technical debt we are going to tackle in 4.3.

Comment 8 errata-xmlrpc 2020-01-23 11:05:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.