Bug 174051 - anaconda does not write grub bootloader
anaconda does not write grub bootloader
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-11-23 21:20 EST by Jason
Modified: 2008-05-06 20:18 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 20:18:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2005-11-23 21:20:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
I just installed FC5T1.  During the install when asked about the bootloader, choosing advanced options etc, I selected edit for the other operating system anaconda identifed.  I wanted to change the name from Other to Windows XP, which I did.  The install proceeded and finished.  I reboot and I get the minimal grub bootloader (no menu like I should have gotten).  When I fixed the problem the grub.conf file still had other instead of windows xp.  I was installing FC5T1 from an IDE CD-ROM to a scsi hard drive.  Windows XP is /dev/sda and Linux is /dev/sdb.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  try to install FC5T1
2.  it fails to install grub
3.
  

Actual Results:  no grub menu like I am supposed to have.  The changes I made during install were not kept.

Expected Results:  grub should have been installed and other should have been windows xp

Additional info:
Comment 1 Jason 2006-01-16 17:27:38 EST
Anaconda still does not write the grub boot loader to my system.  I still have
to set it up manually.
Comment 2 Jason 2006-01-25 10:21:15 EST
Will anaconda write the grub bootloader for FC5T3?
Comment 3 Jason 2006-02-13 11:41:18 EST
Can I please get an update for this bug?  To repeat: anaconda does not write the
grub bootloader to the MBR so after the install I cannot boot.
Comment 4 Jeremy Katz 2006-02-14 14:41:54 EST
I haven't seen anything like this here on any of my installs.  What does
/boot/grub/device.map and /boot/grub/grub.conf look like?  Also (a little
harder), what's the output on tty5 when we the boot loader is installed in anaconda?
Comment 5 Jason 2006-02-15 07:35:17 EST
# this device map was generated by anaconda
(fd0)     /dev/fd0
(hd0)     /dev/sda

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd1,0)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd1,0)/grub/splash.xpm.gz
title Fedora Core (2.6.15-1.1948_FC5)
        root (hd1,0)
        kernel /vmlinuz-2.6.15-1.1948_FC5 ro root=/dev/VolGroup00/LogVol00 lapic
        initrd /initrd-2.6.15-1.1948_FC5.img
title Fedora Core (2.6.15-1.1939_FC5)
        root (hd1,0)
        kernel /vmlinuz-2.6.15-1.1939_FC5 ro root=/dev/VolGroup00/LogVol00 lapic
        initrd /initrd-2.6.15-1.1939_FC5.img
title Windows XP
        rootnoverify (hd0,0)
        chainloader +1

As far as the output from tty5 I don't have that.  If I get time tomorrow I will
reinstall from the test 2 cds else if test3 is still going to be released on
monday I will post those results.  
Comment 6 Jason 2006-02-15 11:13:43 EST
I tried to reinstall FC5T2 today.  When I switched windows my PC froze.  Only
the reset button was able to reboot the system.  I will try to setup a webserver
on my other PC, download the devel tree, burn the boot.iso, and install from that.
Comment 7 Jason 2006-02-15 15:59:13 EST
I tried todays boot.iso and my pc freezes when I switch windows.  I opened
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=181679 about this.  Are you
sure you meant F5?  Before the freeze I was able to look at F5 and it was a
blinking cursor.  Also when during the install process does grub get written to
the MBR so I can switch and look?

Thanks,
Jason
Comment 8 Jason 2006-02-20 15:18:37 EST
I installed FC5T3 today.  Here is the information you requested.

gnu grub 0.97
grub> root (hd1,0)
Error 21: Selected disk does not exist

grub> install /grub/stage1 d (hd0) /grub/stage2 p (hd1,0)/grub/grub.conf
Error 12: invalid device requested
Comment 9 Tommy 2006-02-25 20:08:59 EST
This seems to still be an issue with test 3.  The grub files were there and
correct, but it seems like it wasn't installed properly.  I got an Error 15 when
booting, before I even got to the menu, so I couldn't boot my XP partition
either.  I had to boot the rescue CD and then run grub and enter the commands
root (hd1,0)
setup (hd0)

in order to make the machine bootable.
Comment 10 Ryan O'Hara 2006-02-26 16:18:34 EST
I am seeing related problems. Note that my install uses a kickstart file and
raid. My boot partition is RAID1, and when it attempts to install grub I see:

Error 16: Inconsistent filesystem structure

on tty5

Once I boot (after install), grub hangs. This is probably expected since grub
had errors during install.
Comment 11 Peter Jones 2006-03-02 13:28:21 EST
Ryan O'Hara's comment is a different issue, and should be fixed.

This:
<i>gnu grub 0.97
grub> root (hd1,0)
Error 21: Selected disk does not exist</i>

Looks like your device.map doesn't have hd1 listed, which is consistent with
your comments above, but I can't reproduce it here.  On the advanced bootloader
configuration screen, is it actually showing both sda and sdb?
Comment 12 Jason 2006-03-06 10:48:57 EST
I will try it today and get back to you.
Comment 13 Jason 2006-03-09 09:14:23 EST
Yes it does.  When it comes to creating the partition layout this is what I do:
the screen that lists sda and sdb and has the options for remove all partitions,
remove linux partitions, etc.  I unselect sda (it is my winxp drive) then I
select remove all linux partitions, and I select the review partition layout
checkbox.  Then I click on next.  I change the layout to what I want (shrink the
swap to 256) and click next.  I then see the grub bootloader screen.  I leave
the defaults and click on next.
I don't know if the above will help, but....

Thanks,
Jason
P.S.  I am sorry it took so long to respond.  I was trying the daily boot.iso
but it has issues so I had to go back to the FC5T3 CD.
Comment 14 Jason 2006-03-27 14:55:36 EST
FC5 final still does not write the grub bootloader to the MBR of my system.
Comment 15 Jason 2006-08-26 15:31:29 EDT
I installed the August 26th rawhide.  I downloaded the boot.iso image and did a
http install.  I answered all of the questions, software downloaded, I rebooted
when prompted, then windows XP booted.  

I dual boot between windows and fedora.  Previously when I installed fedora I
would get the minimal grub loader screen.  As of todays install, grub does not
even install.  Windows XP is /dev/sda and fedora is /dev/sdb.
Comment 16 Jason 2006-10-09 19:11:46 EDT
A reinstall of todays rawhide and I still have install grub manually.
Comment 17 Jason 2006-10-18 11:11:17 EDT
I did a wipe and reinstall of October 17's rawhide and this bug is still here. 
 There is at least one other user who has this same problem:
https://www.redhat.com/archives/fedora-test-list/2006-October/msg00450.html

I realize that it is too late to get this fixed for FC6 but this bug has been
around for two years.  Can someone please get around to fixing it?
Comment 18 Bug Zapper 2008-04-03 12:39:22 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 19 Bug Zapper 2008-05-06 20:18:12 EDT
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

Note You need to log in before you can comment on or make changes to this bug.