Bug 174053 - cups upgrade destroys prior configuration
cups upgrade destroys prior configuration
Status: CLOSED DUPLICATE of bug 168485
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-23 21:36 EST by JW
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-24 04:18:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JW 2005-11-23 21:36:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE 6.0; Windows; U; AIIEEEE!; Win98; Windows 98; en-US; Gecko masquerading as IE; should it matter?; rv:1.8b) Gecko/20050217

Description of problem:
Upgrading cups doesnt completely preserve configuration information in /etc/cups/cupsd.conf, neither does it save a copy of previous contents in a polite manner

Version-Release number of selected component (if applicable):
cups-1.1.23-15.1

How reproducible:
Always

Steps to Reproduce:
1.rpom -Fvh cups-1.1.23-15.1.i386.rpm
2.
3.
  

Actual Results:  Modifications to /etc/cups/cupsd.conf disappear

Expected Results:  Modifications to /etc/cups/cupsd.conf should be retained, else cupsd.conf.rpmsave or cupsd.conf.rpmnew should be created


Additional info:

Very important to retain "Listen" lines and "Allow From" lines in all sections.
That includes the "automatically generated" section.
Comment 1 Tim Waugh 2005-11-24 04:18:21 EST

*** This bug has been marked as a duplicate of 168485 ***

Note You need to log in before you can comment on or make changes to this bug.