Bug 1740543 - [IPI] [OSP] FIP address assigned to bootstrap node is not released after bootstrap node is deleted
Summary: [IPI] [OSP] FIP address assigned to bootstrap node is not released after boot...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Martin André
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-13 08:52 UTC by David Sanz
Modified: 2019-10-16 06:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:35:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 2128 None closed Bug 1740543: Consolidate bootstrap resources to bootstrap module 2020-02-07 14:56:28 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:36:06 UTC

Description David Sanz 2019-08-13 08:52:15 UTC
Description of problem:

New installation without service vm creates a floating IP and assigns it to bootstrap node. After this node is deleted, FIP remains assigned to a port and cannot be removed.

When cluster is deleted, this FIP is not returned to the pool and keeps the description talking about the cluster used, when it does not exists anymore.

Version-Release number of the following components:
$ ./openshift-install version
./openshift-install v4.2.0-201908120219-dirty
built from commit 8db0de0082ceefba04327fc9d767095da3db8d69
release image registry.svc.ci.openshift.org/ocp/release@sha256:11a2ac7d12ed1de5b402208d5bc3d7bdc2975f02c93826e8d9ea677113f182f1

How reproducible:

Steps to Reproduce:
1.Install OCP on OSP
2.After bootstrap node deletion step, FIP assigned to it remains assigned
3.After deleting cluster, FIP is also still there

Actual results:
FIP created is not returned to the pool

Expected results:
FIP is returned to the pool when it is not necessary.

Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Eric Duen 2019-08-15 15:55:51 UTC
Martin can you take a look.

Comment 3 David Sanz 2019-08-23 08:07:36 UTC
Verified on 4.2.0-0.nightly-2019-08-23-073712

Comment 4 errata-xmlrpc 2019-10-16 06:35:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.