Bug 174060 - at (and others) fail to compile with WITH_SELINUX=0
Summary: at (and others) fail to compile with WITH_SELINUX=0
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: at   
(Show other bugs)
Version: 4
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-24 06:33 UTC by JW
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-30 17:19:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix at.spec SELINUX conditional build (331 bytes, patch)
2005-11-24 06:55 UTC, JW
no flags Details | Diff

Description JW 2005-11-24 06:33:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE 6.0; Windows; U; AIIEEEE!; Win98; Windows 98; en-US; Gecko masquerading as IE; should it matter?; rv:1.8b) Gecko/20050217

Description of problem:
When compiling at (and other programs with autoconf) with SELINUX disabled a lot of the patches fail because they expect to see WITH_SELINUX macros in text which has been diff'ed.


Version-Release number of selected component (if applicable):
at-3.1.8-77_FC4

How reproducible:
Always

Steps to Reproduce:
1.rpmbuild -v -ba --define "WITH_SELINUX 0" at.spec
2.
3.
  

Actual Results:  2 out of 2 hunks FAILED
etc
etc


Expected Results:  Compile should work!


Additional info:

The problem is if you have a patch that conditionally adds code to configure.in then you have patches that patch code which may or may not have WITH_SELINUX and SELINUXLIB macros in them then you break a lot of patches.
So when, for example, Makefile.in is generated and it has no $(SELINUXLIB) macro in it (instead of just an empty one) then subsequent patches are going to fail.

Comment 1 JW 2005-11-24 06:55:02 UTC
Created attachment 121434 [details]
Patch to fix at.spec SELINUX conditional build

You have to ensure that the "at-selinux.patch" (Patch22) is applied even if
WITH_SELINUX is 0 otherwise subsequent patches will fail.

Comment 2 Jason Vas Dias 2005-11-30 17:19:35 UTC
at does not need to compile without SELinux support - hence, this is NOTABUG.
A new enhanced version of at that I am working on will move SELinux support to
a separate source file, which should make compilation without SELinux much easier.


Note You need to log in before you can comment on or make changes to this bug.