Bug 1740715 - Fail before getting to creation of the Heat stack if EnableRhcs4Beta is not True on deploy and upgrade
Summary: Fail before getting to creation of the Heat stack if EnableRhcs4Beta is not T...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 15.0 (Stein)
Assignee: Francesco Pantano
QA Contact: Eliad Cohen
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-13 14:35 UTC by Giulio Fidente
Modified: 2019-09-27 10:44 UTC (History)
11 users (show)

Fixed In Version: openstack-tripleo-common-10.8.1-0.20190820150508.913b8de.el8ost python-tripleoclient-11.5.1-0.20190820202025.b583929.el8ost
Doc Type: Technology Preview
Doc Text:
Because Red Hat Ceph Storage 4 is at beta when Red Hat OpenStack Platform 15 is at GA, a new configuration option has been added to RHOSP 15 to prevent any accidental deployments of Red Hat Ceph Storage 4 Beta in a production environment. The new Orchestration service (heat) configuration option, EnableRhcs4Beta, is set by default to "False", and therefore prevents director from deploying Red Hat Ceph Storage 4 Beta by accident.
Clone Of:
Environment:
Last Closed: 2019-09-21 11:24:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1746489 0 urgent CLOSED EnableRhcs4Beta failure message needs revision 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:24:41 UTC

Description Giulio Fidente 2019-08-13 14:35:05 UTC
We should stop the deployment (or upgrade) before getting to the point wher Heat starts updating the stack if Ceph is deployed but EnableRhcs4Beta is not enabled

Comment 4 Lon Hohberger 2019-08-21 11:24:04 UTC
Yes, I rebuilt downstream:

python-tripleoclient-11.5.1-0.20190820202025.b583929.el8ost contains  0007-DOWNSTREAM-ONLY-Fail-upgrade-to-15-with-rhcs4-early.patch

Comment 18 errata-xmlrpc 2019-09-21 11:24:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.