Bug 1740782 - [Workload-DFG] RGW Multisite Sync fairness imbalance [NEEDINFO]
Summary: [Workload-DFG] RGW Multisite Sync fairness imbalance
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat Storage
Component: RGW-Multisite
Version: 3.2
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 7.0
Assignee: shilpa
QA Contact: Tejas
Rivka Pollack
URL:
Whiteboard:
: 1831157 1831729 1889214 (view as bug list)
Depends On:
Blocks: 1831661 1727980 1831729 2237662
TreeView+ depends on / blocked
 
Reported: 2019-08-13 15:38 UTC by Tim Wilkinson
Modified: 2024-05-20 10:06 UTC (History)
14 users (show)

Fixed In Version: ceph-18.2.0-2
Doc Type: Enhancement
Doc Text:
.Multi-site sync instances now dynamically spread workloads among themselves Previously, the Ceph Object Gateway multi-site throughput was generally limited to the available bandwidth of a single instance. With this enhancement, Ceph Object Gateway multisite sync instances dynamically parallelize workload among themselves, using a work sharing algorithm. As a result, the scalability is now significantly improved and sync workloads are divided evenly throughout the sync.
Clone Of:
: 1831729 (view as bug list)
Environment:
Last Closed: 2023-12-13 15:18:25 UTC
Embargoed:
akraj: needinfo? (smanjara)


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Ceph Project Bug Tracker 41230 0 None None None 2019-08-13 15:41:54 UTC
Github ceph ceph pull 28119 0 None open rgw: multisite sync fairness 2021-02-16 13:43:32 UTC
Red Hat Product Errata RHBA-2023:7780 0 None None None 2023-12-13 15:18:35 UTC

Comment 11 Matt Benjamin (redhat) 2020-05-05 14:26:17 UTC
*** Bug 1831157 has been marked as a duplicate of this bug. ***

Comment 13 Vikhyat Umrao 2021-10-21 20:12:25 UTC
*** Bug 1831729 has been marked as a duplicate of this bug. ***

Comment 56 errata-xmlrpc 2023-12-13 15:18:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat Ceph Storage 7.0 Bug Fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2023:7780


Note You need to log in before you can comment on or make changes to this bug.