Bug 174090 - links to FC5T1 release-note of other languages are missing
links to FC5T1 release-note of other languages are missing
Status: CLOSED RAWHIDE
Product: Fedora Documentation
Classification: Fedora
Component: docs-requests (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Webmaster
Karsten Wade
http://fedora.redhat.com/docs/release...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-24 07:39 EST by Yoshihiro Totaka
Modified: 2009-08-05 14:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-05 21:44:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yoshihiro Totaka 2005-11-24 07:39:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
rawhide of release note shows that there are 4 translated version of release-notes. However there is no link from release-notes page.

Also it would be fantastic, if we could just browse download server and find the other languages' release-notes.

Rawhide of doc
http://webtest.fedora.redhat.com/docs/RELEASE-NOTES/
Download server
http://download.fedora.redhat.com/pub/fedora/linux/core/test/4.90/i386/os/

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Look for Japanese (some other language) release-note for FC5T1
2.
3.
  

Actual Results:  People can not find it because there is no link from release-note page.

Expected Results:  Links to other languages' release note page.

Additional info:
Comment 1 Paul W. Frields 2005-11-24 16:40:51 EST
We can't get these to test1, since it's out the proverbial barn door at this
point, but we *can* get them to the Web site.  If anyone knows any reason why
these docs should not be joined to the f.r.c site in unholy publication, speak
now or forever hold your peace.  The way I see it, we can label the docs as
"testing" on the overall release notes page.

I am not making the link on the f.r.c page just so some higher (or at least
second) authority can decide this is the right course of action.  In the
meantime, the docs are built and PHP'd, and in the web CVS.
Comment 2 Paul W. Frields 2005-11-24 16:41:56 EST
By the way, they are not tagged LIVE yet either.  Just another safety check.
Comment 3 Stuart Ellis 2005-11-24 17:31:09 EST
OK. So that you know: we had to do some edits post-release to fix some entity
and content bugs, so the translations will now be slightly out of sync with the
en version in Doc CVS.
Comment 4 Paul W. Frields 2005-11-25 10:47:02 EST
I saw those flying across fedora-docs-commits, which is why I didn't feel
totally comfortable tagging these LIVE for the web and linking them from the
main relnotes page.  I will leave that to "The Next Guy," just so it doesn't
look like a stroke of hubris. :-)
Comment 5 Karsten Wade 2005-11-25 22:07:24 EST
There is a difference between the untranslated, latest relnotes and the
translated notes.  The translated ones are equal to the more incomplete notes
that shipped with the ISO.  In other words, what is in HEAD in CVS (and now
tagged FC-5-LATEST) is very different than what was tagged
FC-5-TEST1-TRANS-FREEZE.  The latter is what was translated and in the test1 ISO.

The key is to somehow make this obvious.  I don't see an implementation from
Paul in CVS, but I'm redoing the page as a table, with the latest highlight at
the top + all latest languages.
Comment 6 Karsten Wade 2005-11-25 22:12:17 EST
http://cvs.fedora.redhat.com/viewcvs/web/html/docs/release-notes/fc5/?root=fedora

ViewCVS to the rescue, thanks Paul!
Comment 7 Karsten Wade 2005-11-26 04:03:58 EST
I dropped a new layout in, a table to make the versions and languages easier to
find.  The [Tip] at the top mirrors the [Tip] that appears on the top of each of
the as-shipped relnotes, I'm happy with that design glue.

This differentiates the versions properly, giving us an obvious location for new
translations.

Any comments, changes before I close this bug?
Comment 8 Patrick Barnes 2005-12-05 21:44:56 EST
For the lack of comment, I'm assuming we are clear to close this bug.

I'm closing this bug as RAWHIDE.  Thank you all for your attention to this issue.
Comment 9 Yoshihiro Totaka 2005-12-07 06:00:26 EST
Sorry about lack of response. I was busy with my personal life. 
It looks great now and thank you all for fix this problem.
Comment 10 eric@christensenplace.us 2009-08-05 14:42:28 EDT
Tickets move to docs-request so the fedora-websites component can be removed per request from Ricky.

Note You need to log in before you can comment on or make changes to this bug.