Bug 174102 - Wrong kernel flavor
Wrong kernel flavor
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-11-24 11:05 EST by Praveen Kumar
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-25 11:51:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Praveen Kumar 2005-11-24 11:05:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
The installer chooses smp version of kernel on Pentium M 1.6 GHz processor

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot using flash drive with diskboot.img
2. FTP Install from mirror.linux.duke.edu
3. Reboot
  

Actual Results:  Anaconda installs smp version of kernel for the uniprocessor version

Expected Results:  It should have installed the uniprocessor version

Additional info:

My laptop: Dell Inspiron 6000D, with Pentium M 730 1.6GHz
Comment 1 Praveen Kumar 2005-11-24 11:11:00 EST
It is a fresh install
Comment 2 Thomas M Steenholdt 2005-11-24 16:37:30 EST
Ditto - With my Pentium M based Shuttle...

I suspect it's purely kernel related, but let us know if you need any other
information.
Comment 3 Ronny Fischer 2005-11-24 16:42:07 EST
This also happens when installing from CD and is not related to a specific 
Laptop model. My one is an IBM R52, 1.73 GHz Pentium M.
Installation seems to be correct. Bootloader starts, but after messaging "OK, 
booting the kernel" and entering initrd, the bootloader stops without any 
further message and restarts the system after a few seconds.
Comment 4 Jeremy Katz 2005-11-24 22:18:44 EST
Can you provide the contents of /proc/cpuinfo?
Comment 5 Franz Hänel 2005-11-25 05:21:06 EST
I have the same problem on my Asus A6V. However I was able to boot with this
kernel argument: mem=nopentium

/proc/cpuinfo

processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 1.73GHz
stepping        : 8
cpu MHz         : 798.120
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat
clflush dts acpi mmx fxsr sse sse2 ss tm pbe nx est tm2
bogomips        : 1599.23
Comment 6 Vladimir Kosovac 2005-11-25 09:39:16 EST
Same here, CD install, i386 release. Laptop is Compaq PresarioM2000, ATi
chipset, AMD64 CPU:

/proc/cpuinfo

processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 36
model name      : AMD Turion(tm) 64 Mobile Technology ML-30
stepping        : 2
cpu MHz         : 1592.082
cache size      : 1024 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36
clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow pni lahf_lm
bogomips        : 3190.57
===================================
Single processor kernel works well.
Comment 7 Jeremy Katz 2005-11-25 11:51:50 EST
Aha, this is correct -- we install the smp kernel since you have NX available
which makes execshield work far better.  Unfortunately, you're then hitting the
kernel bug called out in the release announcement which should be fixed in
rawhide soon (if not already -- I haven't talked with davej since before
Thanksgiving and he may have done a build to fix it)
Comment 8 Thomas M Steenholdt 2005-11-27 04:35:04 EST
Jeremy, just to make things clear, SHOULD we be running the SMP kernel even
though our CPUs are single core, non-hyperthreaded ones?
Are we losing functionality/performance/security by selecting the UP kernel
manually?
It looks like this to me when I'm readin comment #7, but I want to make sure.
If it really makes sense to run the SMP kernel on our systems, we shouldn't all
manually change to the UP kernel, with the feeling that "this works much better".
That said, I can't see right now why some such functionality would not be
available in the UP kernel?
Thanks.

Note You need to log in before you can comment on or make changes to this bug.