Bug 174109 - system-config-lvm crashes with BlockDevice.BlockDeviceErr_extended
system-config-lvm crashes with BlockDevice.BlockDeviceErr_extended
Status: CLOSED DUPLICATE of bug 169860
Product: Fedora
Classification: Fedora
Component: system-config-lvm (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Jim Parsons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-24 12:14 EST by Clyde E. Kunkel
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 17:56:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clyde E. Kunkel 2005-11-24 12:14:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
From root terminal get following traceback with trying to invoke system-config-lvm:

[root@P4C800Deluxe ~]# system-config-lvm
Traceback (most recent call last):
  File "/usr/sbin/system-config-lvm", line 138, in ?
    runFullGUI()
  File "/usr/sbin/system-config-lvm", line 123, in runFullGUI
    blvm = baselvm(glade_xml, app)
  File "/usr/sbin/system-config-lvm", line 68, in __init__
    self.lvmm = lvm_model()
  File "/usr/share/system-config-lvm/lvm_model.py", line 142, in __init__
    self.__block_device_model = BlockDeviceModel()
  File "/usr/share/system-config-lvm/BlockDeviceModel.py", line 19, in __init__
    bd = BlockDevice(devname)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 41, in __init__
    self.reload()
  File "/usr/share/system-config-lvm/BlockDevice.py", line 62, in reload
    self.addNoAlign(part.beg, part.end, part.id, part.bootable, part.num)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 200, in addNoAlign
    raise BlockDeviceErr_extended()
BlockDevice.BlockDeviceErr_extended: <BlockDevice.BlockDeviceErr_extended instance at 0xb7b7428c>


Version-Release number of selected component (if applicable):
  LVM version:     2.01.14 (2005-08-04)
  Library version: 1.01.05 (2005-09-26)
  Driver version:  4.4.0

How reproducible:
Always

Steps to Reproduce:
1. # system-config-lvm
2.
3.
  

Actual Results:  crashes per description

Expected Results:  LVM gui should come up.

Additional info:

Checked the consistency of VGs, nothing reported.
Comment 1 Clyde E. Kunkel 2005-11-25 10:30:34 EST
11/15/05

Hmmmm....working now.  Don't recall if I upgraded to latest rawhide after the
crash or before and rebooted or not.  At any rate, works now and actually shows
a much improved graphic of the VGs and LVs vs what was displayed pre-FC5T1.  Nice.

However, would like to see some indication that an error of some sort has
occured when invoking from the menu tree.  Saves time and would allow a savvy
user to immediately go to the command line for further research.
Comment 2 Clyde E. Kunkel 2005-11-25 10:47:42 EST
Well, sorry, spoke too soon.  Went to another test machine that does not have
any LGs, just software raidsets and normal linux partitions.  No
system-config-lvm installed, so: yum install system-config-lvm from development,
no errors.  Reboot machine.  Gui fails, so go to command line, invoke, and see:

Traceback (most recent call last):
  File "/usr/sbin/system-config-lvm", line 138, in ?
    runFullGUI()
  File "/usr/sbin/system-config-lvm", line 123, in runFullGUI
    blvm = baselvm(glade_xml, app)
  File "/usr/sbin/system-config-lvm", line 68, in __init__
    self.lvmm = lvm_model()
  File "/usr/share/system-config-lvm/lvm_model.py", line 142, in __init__
    self.__block_device_model = BlockDeviceModel()
  File "/usr/share/system-config-lvm/BlockDeviceModel.py", line 19, in __init__
    bd = BlockDevice(devname)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 41, in __init__
    self.reload()
  File "/usr/share/system-config-lvm/BlockDevice.py", line 62, in reload
    self.addNoAlign(part.beg, part.end, part.id, part.bootable, part.num)
  File "/usr/share/system-config-lvm/BlockDevice.py", line 200, in addNoAlign
    raise BlockDeviceErr_extended()
BlockDevice.BlockDeviceErr_extended: <BlockDevice.BlockDeviceErr_extended
instance at 0xb7b331ec>

LVM2 is installed.

[root@P4C800ED ~]# rpm -q lvm2
lvm2-2.01.14-4
[root@P4C800ED ~]# lvm version
  LVM version:     2.01.14 (2005-08-04)
  Library version: 1.01.05 (2005-09-26)
  Driver version:  4.4.0
[root@P4C800ED ~]# system-config-lvm --version
Gnome system-config-lvm 1.0.8
Comment 3 Stanko Kupcevic 2005-12-19 14:19:32 EST
Could you post an output of

sfdisk -uS -l /dev/sda

for all your hard drives. It would help me debug it.
Comment 4 Clyde E. Kunkel 2005-12-19 16:34:25 EST
[root@P4C800ED ~]# sfdisk -uS -l /dev/hda

Disk /dev/hda: 24792 cylinders, 255 heads, 63 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/hda1   *        63   2249099    2249037  83  Linux
/dev/hda2       2249100   6458129    4209030  82  Linux swap / Solaris
/dev/hda3       6763365  52114859   45351495   7  HPFS/NTFS
/dev/hda4      52114860 398283479  346168620   f  W95 Ext'd (LBA)
/dev/hda5      52114923  93096674   40981752   7  HPFS/NTFS
                start: (c,h,s) expected (1023,254,63) found (1023,1,1)
/dev/hda6      93096738 139877954   46781217   b  W95 FAT32
/dev/hda7     139878018 140086799     208782   6  FAT16
/dev/hda8     140086863 191302019   51215157  fd  Linux raid autodetect
/dev/hda9     191302083 242517239   51215157  fd  Linux raid autodetect
/dev/hda10    242517303 293732459   51215157  fd  Linux raid autodetect
/dev/hda11    293732523 344947679   51215157  fd  Linux raid autodetect
/dev/hda12    344947743 398283479   53335737  83  Linux
[root@P4C800ED ~]# sfdisk -uS -l /dev/hdb

Disk /dev/hdb: 19929 cylinders, 255 heads, 63 sectors/track
Warning: extended partition does not start at a cylinder boundary.
DOS and Linux will interpret the contents differently.
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/hdb1            63 160923104  160923042   f  W95 Ext'd (LBA)
/dev/hdb2   * 160923105 266823584  105900480   7  HPFS/NTFS
/dev/hdb3     266823585 320159384   53335800  fd  Linux raid autodetect
/dev/hdb4             0         -          0   0  Empty
/dev/hdb5           126    208844     208719  83  Linux
/dev/hdb6        208908   1220939    1012032  82  Linux swap / Solaris
/dev/hdb7       1221003  38025854   36804852  fd  Linux raid autodetect
/dev/hdb8      38025918  78991604   40965687  fd  Linux raid autodetect
/dev/hdb9      78991668 119957354   40965687  fd  Linux raid autodetect
/dev/hdb10    119957418 160923104   40965687  fd  Linux raid autodetect
[root@P4C800ED ~]# sfdisk -uS -l /dev/hde

Disk /dev/hde: 30515 cylinders, 255 heads, 63 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/hde1   *        63    417689     417627  83  Linux
/dev/hde2        417690  39487769   39070080  fd  Linux raid autodetect
/dev/hde3      39487770  80453519   40965750  fd  Linux raid autodetect
                start: (c,h,s) expected (1023,254,63) found (1023,0,1)
/dev/hde4      80453520 490223474  409769955   f  W95 Ext'd (LBA)
                start: (c,h,s) expected (1023,254,63) found (1023,0,1)
/dev/hde5      80453583 121419269   40965687  fd  Linux raid autodetect
                start: (c,h,s) expected (1023,254,63) found (1023,1,1)
/dev/hde6     121419333 180024389   58605057  83  Linux
                start: (c,h,s) expected (1023,254,63) found (1023,1,1)
/dev/hde7     180024453 219110534   39086082  fd  Linux raid autodetect
                start: (c,h,s) expected (1023,254,63) found (1023,1,1)
/dev/hde8     219110598 258196679   39086082  83  Linux
                start: (c,h,s) expected (1023,254,63) found (1023,1,1)
/dev/hde9     258196743 319645304   61448562  83  Linux
                start: (c,h,s) expected (1023,254,63) found (1023,1,1)
/dev/hde10    319645368 370844459   51199092  fd  Linux raid autodetect
                start: (c,h,s) expected (1023,254,63) found (1023,1,1)
/dev/hde11    370844523 411810209   40965687  fd  Linux raid autodetect
                start: (c,h,s) expected (1023,254,63) found (1023,1,1)
/dev/hde12    411810273 452775959   40965687  fd  Linux raid autodetect
/dev/hde13    452776023 490223474   37447452  83  Linux
[root@P4C800ED ~]# sfdisk -uS -l /dev/sda

Disk /dev/sda: 14946 cylinders, 255 heads, 63 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sda1   *        63  36869174   36869112  fd  Linux raid autodetect
/dev/sda2      36869175  69641774   32772600  fd  Linux raid autodetect
/dev/sda3      69641775 240107489  170465715   f  W95 Ext'd (LBA)
/dev/sda4             0         -          0   0  Empty
/dev/sda5      69641838 110607524   40965687  fd  Linux raid autodetect
/dev/sda6     110607588 155669849   45062262  fd  Linux raid autodetect
/dev/sda7     155669913 196635599   40965687  fd  Linux raid autodetect
/dev/sda8     196635663 240107489   43471827  fd  Linux raid autodetect
[root@P4C800ED ~]# sfdisk -uS -l /dev/sdb

Disk /dev/sdb: 14946 cylinders, 255 heads, 63 sectors/track
Units = sectors of 512 bytes, counting from 0

   Device Boot    Start       End   #sectors  Id  System
/dev/sdb1   *        63  36869174   36869112  fd  Linux raid autodetect
/dev/sdb2      36869175  69641774   32772600  fd  Linux raid autodetect
/dev/sdb3      69641775 240107489  170465715   f  W95 Ext'd (LBA)
/dev/sdb4             0         -          0   0  Empty
/dev/sdb5      69641838 110607524   40965687  fd  Linux raid autodetect
/dev/sdb6     110607588 155669849   45062262  fd  Linux raid autodetect
/dev/sdb7     155669913 196635599   40965687  fd  Linux raid autodetect
/dev/sdb8     196635663 240107489   43471827  fd  Linux raid autodetect
[root@P4C800ED ~]#

Comment 5 Stanko Kupcevic 2005-12-19 17:56:53 EST

*** This bug has been marked as a duplicate of 169860 ***

Note You need to log in before you can comment on or make changes to this bug.