Bug 1741100 - python2-paste-script fails to install in Fedora 31+
Summary: python2-paste-script fails to install in Fedora 31+
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-paste-script
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Andrea
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F31FailsToInstall PY2FTBI
TreeView+ depends on / blocked
 
Reported: 2019-08-14 09:13 UTC by Miro Hrončok
Modified: 2019-08-19 10:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-19 10:56:48 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2019-08-14 09:13:34 UTC
python2-paste-script-3.1.0-2.fc31.noarch fails to install in Fedora rawhide:

  nothing provides python2-cherrypy needed by python2-paste-script-3.1.0-2.fc31.noarch

This is most likely caused by a dependency that was retired.
Please drop the dependency, unretire the dependency or remove the package. Thanks

Comment 1 Andrea 2019-08-14 09:48:43 UTC
ok i will remove python2-paste-script from rawhide/f31 and keep only python3-paste-script

Comment 2 Andrea 2019-08-19 09:37:02 UTC
i feel a bit stupid:-)

i have tried to modify the spec file  to include the python2 package only in releases <= 30, but i still see the python2 package built

https://koji.fedoraproject.org/koji/buildinfo?buildID=1356940

what is the correct syntax for this?

https://src.fedoraproject.org/rpms/python-paste-script/blob/master/f/python-paste-script.spec

thanks!

Comment 3 Miro Hrončok 2019-08-19 09:55:35 UTC
%if %{?fedora}%{!?fedora:0} <= 30 || %{?rhel}%{!?rhel:0} <= 8


This translates to (on Fedora 32):

 32 <= 30 || 0 <= 8

Or (on RHEL 8):

 0 <= 30 || 8 <= 8


I.e. it is always true.

If you really need a crazy conditions like that, here's how to do it:

%if (0%{?fedora} && (0%{?fedora} <= 30)) || (0%{?rhel} && (0%{?rhel} <= 8))

Comment 4 Andrea 2019-08-19 10:56:48 UTC
thanks!
i have applied the changes both on Rawhide

https://koji.fedoraproject.org/koji/taskinfo?taskID=37149509


and F31

https://koji.fedoraproject.org/koji/taskinfo?taskID=37149816


Note You need to log in before you can comment on or make changes to this bug.