Bug 1741132 - Switch to GiB/TiB rather than Gi/Ti
Summary: Switch to GiB/TiB rather than Gi/Ti
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: Andy Braren
QA Contact: Yadan Pei
URL:
Whiteboard:
: 1772569 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-14 10:56 UTC by Tomas Jelinek
Modified: 2020-05-04 11:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:13:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2296 'None' closed Bug 1741132: Add "B" to the end of binary unit labels 2020-05-04 02:16:59 UTC
Github openshift console pull 3942 None closed Bug 1741132: Fix PVC dropdown unit label behavior 2020-05-04 02:16:59 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:13:35 UTC

Description Tomas Jelinek 2019-08-14 10:56:42 UTC
https://github.com/openshift/console/pull/2296

Comment 1 Tomas Jelinek 2019-08-14 10:57:46 UTC
https://github.com/openshift/console/pull/2296

Comment 2 W. Trevor King 2019-10-04 17:28:49 UTC
Lots of conflicts on the PR per GitHub, and PR targets master.  I'm going to punt this to 4.3.0.

Comment 4 shahan 2019-11-05 08:12:17 UTC
I checked dashboad, pv, pvc, limit range pages, they all updated to GiB/TiB
But the 'Max' in table of Resource Quota Details page did not change.
did it changed by this pr? I'll assign back firstly.

Comment 5 Samuel Padgett 2019-11-14 16:29:33 UTC
*** Bug 1772569 has been marked as a duplicate of this bug. ***

Comment 6 shahan 2019-12-24 05:58:09 UTC
Goto Storage->pvc page->create pvc, Switch GiB/TiB/MiB in size dropdown, it will change to Gi/Ti/Mi toggle text

Comment 7 Andy Braren 2020-01-06 20:39:46 UTC
I believe seeing Mi/Gi in the Max column of a Resource Quota Details page is okay, because that table directly reflects what's in the YAML (each row is a field, each Max has the value without any spaces).

The behavior in the Create PVC form is odd though and I'm not sure how to fix it. I notice if you click the value in the dropdown again, it'll switch to GiB correctly. zherman@redhat.com we did the reverse of this change a year ago in https://github.com/openshift/console/pull/1228, any idea how to fix this?

Comment 9 Zac Herman 2020-01-13 16:19:53 UTC
Yeah, so things are pretty messed up on that page currently.  Last year I was asked to changed it, so it is funny we have now changed it back.  I think you need to make both the value and key values have 'B', so  const dropdownUnits = {
    MiB: 'MiB',
    GiB: 'GiB',
    TiB: 'TiB',
  };
Also, you need to change the default value set in the useState:
  const [requestSizeUnit, setRequestSizeUnit] = React.useState('GiB');

I think that should fix it but I did not test that change.

Comment 10 Zac Herman 2020-01-14 02:48:28 UTC
@abraren - see my note above

Comment 11 Andy Braren 2020-01-14 04:55:18 UTC
@zherman I think followed your note correctly in this PR, which does fix the dropdown behavior, but introduces a validation issue :( https://github.com/openshift/console/pull/3942

Comment 14 shahan 2020-02-20 09:03:08 UTC
Goto Storage->pvc page->create pvc, Switch GiB/TiB/MiB in size dropdown, it will be GiB/TiB/MiB toggle text
4.4.0-0.nightly-2020-02-19-041512

Comment 16 errata-xmlrpc 2020-05-04 11:13:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.