Bug 1741135 - DC doesn't adopt RCs
Summary: DC doesn't adopt RCs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-controller-manager
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.1.z
Assignee: Tomáš Nožička
QA Contact: zhou ying
URL:
Whiteboard: workloads
: 1744486 (view as bug list)
Depends On: 1741133
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-14 10:59 UTC by Tomáš Nožička
Modified: 2019-09-20 12:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1741133
Environment:
Last Closed: 2019-09-20 12:29:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 23731 'None' 'closed' 'Bug 1741135: Fix dc adoption' 2019-11-20 08:10:33 UTC
Red Hat Product Errata RHBA-2019:2768 None None None 2019-09-20 12:29:38 UTC

Description Tomáš Nožička 2019-08-14 10:59:01 UTC
+++ This bug was initially created as a clone of Bug #1741133 +++

Description of problem:


for any DC this should work:

`oc create -f dc.yaml`

2x `oc rollout latest`

`oc delete -f dc.yaml --cascade=false`

`oc create -f dc.yaml`

dc latest version should be 3

`oc rollout latest` should create rc #4

Comment 1 Tomáš Nožička 2019-09-05 11:55:17 UTC
*** Bug 1744486 has been marked as a duplicate of this bug. ***

Comment 3 zhou ying 2019-09-09 05:27:36 UTC
Confirmed with latest version, the issue has fixed:
[root@dhcp-140-138 filejob]# oc get dc 
NAME                 REVISION   DESIRED   CURRENT   TRIGGERED BY
deployment-example   2          1         1         config,image(deployment-example:latest)
[root@dhcp-140-138 filejob]# oc delete -f dc.yaml --cascade=false
deploymentconfig.apps.openshift.io "deployment-example" deleted

[root@dhcp-140-138 filejob]# oc get rc
NAME                   DESIRED   CURRENT   READY   AGE
deployment-example-1   0         0         0       7m8s
deployment-example-2   1         1         1       3m48s
[root@dhcp-140-138 filejob]# oc get dc
No resources found.
[root@dhcp-140-138 filejob]# oc create -f dc.yaml 
deploymentconfig.apps.openshift.io/deployment-example created
[root@dhcp-140-138 filejob]# oc get dc 
NAME                 REVISION   DESIRED   CURRENT   TRIGGERED BY
deployment-example   2          1         1         config,image(deployment-example:latest)
[root@dhcp-140-138 filejob]# oc get rc
NAME                   DESIRED   CURRENT   READY   AGE
deployment-example-1   0         0         0       7m46s
deployment-example-2   1         1         1       4m26s
[root@dhcp-140-138 filejob]# oc rollout latest dc/deployment-example 
deploymentconfig.apps.openshift.io/deployment-example rolled out
[root@dhcp-140-138 filejob]# oc get rc
NAME                   DESIRED   CURRENT   READY   AGE
deployment-example-1   0         0         0       13m
deployment-example-2   0         0         0       10m
deployment-example-3   1         1         1       42s

Comment 5 errata-xmlrpc 2019-09-20 12:29:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2768


Note You need to log in before you can comment on or make changes to this bug.