Bug 1741325 - python2-policycoreutils removed but not obsoleted (prevents main package being updated if python2-policycoreutils is installed)
Summary: python2-policycoreutils removed but not obsoleted (prevents main package bein...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-obsolete-packages
Version: 31
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jason Tibbitts
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-14 19:23 UTC by Adam Williamson
Modified: 2020-04-06 19:38 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-23 10:26:45 UTC
Type: Bug


Attachments (Terms of Use)

Description Adam Williamson 2019-08-14 19:23:07 UTC
python2-policycoreutils seems to have been removed, but not obsoleted. This causes problems on update:

 Problem 2: package python2-policycoreutils-2.9-1.fc31.noarch requires policycoreutils = 2.9-1.fc31, but none of the providers can be installed
  - cannot install both policycoreutils-2.9-3.fc31.x86_64 and policycoreutils-2.9-1.fc31.x86_64
  - problem with installed package python2-policycoreutils-2.9-1.fc31.noarch
  - cannot install the best update candidate for package policycoreutils-2.9-1.fc31.x86_64

please have something, probably policycoreutils itself, obsolete python2-policycoreutils (in F31 and Rawhide both).

Comment 1 Petr Lautrbach 2019-08-23 08:11:27 UTC
I guess it should be obsoleted in fedora-obsolete-packages -
https://fedoraproject.org/wiki/Changes/F31_Mass_Python_2_Package_Removal :

Upgrade failures because of missing dependencies should be treated as bugs. Any removed python2 subpackages which break upgrades need to be added to Obsoletes in fedora-obsolete-packages.

Comment 2 Petr Lautrbach 2019-08-23 08:15:23 UTC
If this is correct, please add to fedora-obsoleted-packages also the following packages: 

- python2-libselinux - #1739646
- python2-libsemanage - #1738466
- python2-setools

Comment 3 Miro Hrončok 2019-08-23 08:53:42 UTC
$ repoquery --repo=rawhide --obsoletes fedora-obsolete-packages | egrep 'policycoreutils|libselinux|libsemanage|setools'
python2-libselinux < 2.9-5
python2-libsemanage < 2.9-3
python2-policycoreutils < 2.9-2
python2-setools < 4.1.1-15


$ repoquery --releasever=31 --repo=fedora --obsoletes fedora-obsolete-packages | egrep 'policycoreutils|libselinux|libsemanage|setools'
python2-libselinux < 2.9-5
python2-libsemanage < 2.9-3
python2-policycoreutils < 2.9-2
python2-setools < 4.1.1-15


Are the versions wrong?

Comment 4 Petr Lautrbach 2019-08-23 10:26:45 UTC
In this case it's already fixed. Thanks and sorry for the noise.

Comment 5 Adam Williamson 2019-08-23 15:41:02 UTC
FWIW I think this was wrong. You're only supposed to use fedora-obsolete-packages to obsolete things if there is no other logical candidate. In this case there clearly *is* another logical candidate: the thing making python2-policycoreutils obsolete is policycoreutils itself, that is what should have obsoleted it.

Comment 6 ozeszty 2020-04-06 17:08:48 UTC
It seems that F32 was somehow omitted and now upgrade from F30 to F32 is blocked:
[root@b b]# dnf repoquery --releasever=32 --repo=fedora --obsoletes fedora-obsolete-packages | egrep 'policycoreutils|libselinux|libsemanage|setools'
Fedora 32 - x86_64                               16 kB/s |  16 kB     00:01    
Fedora 32 - x86_64                              693 kB/s | 6.6 MB     00:09    
Ostatnio sprawdzono ważność metadanych: 0:00:18 temu w dniu pon, 6 kwi 2020, 18:55:24.
[root@b b]# dnf repoquery --releasever=31 --repo=fedora --obsoletes fedora-obsolete-packages | egrep 'policycoreutils|libselinux|libsemanage|setools'
Ostatnio sprawdzono ważność metadanych: 1:49:41 temu w dniu pon, 6 kwi 2020, 17:06:39.
python2-libselinux < 2.9-5
python2-libsemanage < 2.9-3
python2-policycoreutils < 2.9-5
python2-setools < 4.1.1-15

I've already reported https://bugzilla.redhat.com/show_bug.cgi?id=1821357 (python2-libselinux) and https://bugzilla.redhat.com/show_bug.cgi?id=1821362 (python2-libsemanage), currently blocking upgrade are also python2-policycoreutils and python2-setools with python2-enum34. Should I report them separately, or will this comment suffice?

Comment 7 Miro Hrončok 2020-04-06 19:38:52 UTC
libsemanage and libselinux are handled in bz1821357

I'll add python2-policycoreutils and python2-setools.

python2-enum34 seem to be obsoleted properly:


$ repoquery --releasever=32 --repo={fedora,updates{,-testing}} --latest=1 --obsoletes fedora-obsolete-packages | egrep 'policycoreutils|libselinux|libsemanage|setools|enum34'
python2-enum34 < 1.1.6-10


No need to open extra bugzillas.


Note You need to log in before you can comment on or make changes to this bug.