Bug 174145 - indic glyph displayed as empty square in X applications
indic glyph displayed as empty square in X applications
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: fonts-indic (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Leon Ho
: i18n
Depends On:
Blocks: Indic
  Show dependency treegraph
 
Reported: 2005-11-24 23:36 EST by Lawrence Lim
Modified: 2014-03-25 20:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-08 17:16:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2005-11-24 23:36:54 EST
Description of problem:
The glyphs for CJK in xterm display ok, but not for indic glyphs which gets
display as empty square.

Version-Release number of selected component (if applicable):
fonts-*-1.10-2

How reproducible:
Always

Steps to Reproduce:
1.Log in with any CJK locale
2.start xterm
3.ctrl-space to acticate scim and select any indic IME
4.enter 'kg'
  
Actual results:
empty square

Expected results:
indic glyph gets displayed

Additional info:
Comment 2 Akira TAGOH 2005-11-25 08:07:07 EST
This problem is due to the lacking of the encoding in X, like the fles under
/usr/X11R6/lib/X11/locale, because xterm still relies on X core font but not
Xft. I just suspect there is any solution without the encoding files.
Comment 3 Leon Ho 2005-12-08 17:16:12 EST
Nothing one can do because it requires bitmap. Even if you have a font, xterm
won't be able to do CTL. If fixing terminal, better spend time to fix in vte
instead. Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.