Bug 1741465 - AllowVolumeExpansion is enabled in default storage class for aws, but not for azure/gcp/openstack/vsphere.
Summary: AllowVolumeExpansion is enabled in default storage class for aws, but not for...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Hemant Kumar
QA Contact: Chao Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-15 08:59 UTC by Liang Xia
Modified: 2019-10-16 06:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:36:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-storage-operator pull 45 0 'None' closed Bug 1741465: Enable volume expansion on platforms where is supported 2020-09-11 01:52:20 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:36:14 UTC

Description Liang Xia 2019-08-15 08:59:33 UTC
Description of problem:
After installation OCP 4.2 cluster on AWS, check the default storage class, allowVolumeExpansion is set to true.
While on azure/gcp/openstack/vsphere, it is not set (which default to false).
As Persistent Volume Resize is a GA feature, we should make enable/disable allowVolumeExpansion in  default storage class consistent across platforms. 

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-08-13-183722

How reproducible:
Always

Steps to Reproduce:
1.Check default storage class on AWS and other platforms.
2.

Actual results:
On AWS, allowVolumeExpansion is set to true.
On Azure/GCP/OpenStack/vSphere, it is not set (which default to false).

Expected results:
As Persistent Volume Resize is a GA feature, we should make enable/disable allowVolumeExpansion in default storage class consistent across platforms. 


Additional info:
https://github.com/openshift/cluster-storage-operator/blob/master/assets/aws.yaml

Comment 1 Hemant Kumar 2019-08-15 15:51:22 UTC
Thanks for bringing this up. It looks like we can enable expansion by default on all platforms except vsphere. vsphere does not support volume expansion.

Comment 4 Chao Yang 2019-08-23 06:14:24 UTC
Verified on OSP with 4.2.0-0.nightly-2019-08-22-153337 
apiVersion: v1
items:
- allowVolumeExpansion: true
  apiVersion: storage.k8s.io/v1
  kind: StorageClass
  metadata:
    annotations:
      storageclass.kubernetes.io/is-default-class: "true"
    creationTimestamp: "2019-08-20T11:25:38Z"
    name: standard
    ownerReferences:
    - apiVersion: v1
      kind: clusteroperator
      name: storage
      uid: ba46256a-c33b-11e9-a948-fa163e4a50bd
    resourceVersion: "10926"
    selfLink: /apis/storage.k8s.io/v1/storageclasses/standard
    uid: 3c50009d-c33d-11e9-8b5f-fa163ea99686
  provisioner: kubernetes.io/cinder
  reclaimPolicy: Delete
  volumeBindingMode: WaitForFirstConsumer
kind: List
metadata:
  resourceVersion: ""
  selfLink: ""

Comment 5 Chao Yang 2019-08-27 02:35:16 UTC
Azure storage class is updated
oc get sc -o yaml
apiVersion: v1
items:
- allowVolumeExpansion: true
  apiVersion: storage.k8s.io/v1
  kind: StorageClass
  metadata:
    annotations:
      storageclass.kubernetes.io/is-default-class: "true"
    creationTimestamp: 2019-08-26T03:18:49Z
    name: managed-premium
    namespace: ""
    ownerReferences:
    - apiVersion: v1
      kind: clusteroperator
      name: storage
      uid: 5249171b-c7af-11e9-8489-000d3a968d5d
    resourceVersion: "8914"
    selfLink: /apis/storage.k8s.io/v1/storageclasses/managed-premium
    uid: 392ff357-c7b0-11e9-bbb0-000d3a968415
  parameters:
    kind: Managed
    storageaccounttype: Premium_LRS
  provisioner: kubernetes.io/azure-disk
  reclaimPolicy: Delete
  volumeBindingMode: WaitForFirstConsumer
kind: List
metadata:
  resourceVersion: ""
  selfLink: ""

Comment 6 Chao Yang 2019-08-28 07:52:37 UTC
AllowVolumeExpansion does not set on vsphere with 4.2.0-0.nightly-2019-08-27-105356 

oc describe sc thin | grep -i expansion
AllowVolumeExpansion:  <unset>

Comment 8 Chao Yang 2019-08-29 06:26:40 UTC
GCE default sc is updated
oc describe sc standard
Name:                  standard
IsDefaultClass:        Yes
Annotations:           storageclass.kubernetes.io/is-default-class=true
Provisioner:           kubernetes.io/gce-pd
Parameters:            replication-type=none,type=pd-standard
AllowVolumeExpansion:  True
MountOptions:          <none>
ReclaimPolicy:         Delete
VolumeBindingMode:     WaitForFirstConsumer
Events:                <none>

Comment 9 errata-xmlrpc 2019-10-16 06:36:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.