Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1741484 - Add --version parameter to webhook cmd and record the version into logs
Summary: Add --version parameter to webhook cmd and record the version into logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Federation
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Ivan Font
QA Contact: Qin Ping
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-15 09:29 UTC by Qin Ping
Modified: 2019-10-16 06:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:36:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:36:14 UTC

Description Qin Ping 2019-08-15 09:29:45 UTC
Description of problem:
Add --version parameter to webhook cmd and record the version into logs

Version-Release number of selected component (if applicable):
KubeFed controller-manager version: version.Info{Version:"v4.2.0", GitCommit:"b8ae65cee603cc9c746911debd3dc23b922222d8", GitTreeState:"clean", BuildDate:"2019-08-13T23:14:02Z", GoVersion:"go1.12.6", Compiler:"gc", Platform:"linux/amd64"}

How reproducible:
100%

Steps to Reproduce:
1. Installed kubefed webhook
2. Try to get version information from the logs
oc logs kubefed-admission-webhook-fd757766b-jcgd5 -n default
3.

Actual results:
Can not find the version information for debug

Expected results:
Hope there is version information like controller-manager command.

Additional info:

Comment 1 Aniket Bhat 2019-08-23 17:32:54 UTC
Ping,

The fix should be available in the latest downstream image.

Comment 3 Qin Ping 2019-08-27 05:01:30 UTC
Verified with: 
$ oc logs deployment/kubefed-admission-webhook -n openshift-federation-system
KubeFed admission webhook version: version.Info{Version:"v4.2.0", GitCommit:"7f002471b9dd8366e1e0f080b46bc79864682f71", GitTreeState:"clean", BuildDate:"2019-08-25T20:09:07Z", GoVersion:"go1.12.6", Compiler:"gc", Platform:"linux/amd64"

Comment 4 errata-xmlrpc 2019-10-16 06:36:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.