Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1741521 - qt5-qtwebkit-devel too old for RHEL7.7
Summary: qt5-qtwebkit-devel too old for RHEL7.7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: qt5-qtwebkit
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-15 11:24 UTC by Thomas Klar
Modified: 2019-09-06 12:28 UTC (History)
6 users (show)

Fixed In Version: qt5-qtwebkit-5.9.1-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-31 01:46:11 UTC
Type: Bug


Attachments (Terms of Use)

Description Thomas Klar 2019-08-15 11:24:10 UTC
Description of problem:

qt5-qtbase got updated in the RHEL repo and now the qt5-qtwebkit can not be installed.

Version-Release number of selected component (if applicable):

5.9.7-2

How reproducible:

100%

Steps to Reproduce:
1. On RHEL 7.6, with qt5-qtbase-5.9.7-2.el7.x86_64 installed
2. yum install install qt5-qtwebkit-devel

Actual results:

Error: Execution of '/bin/yum -d 0 -e 0 -y install qt5-qtwebkit-devel' returned 1: Error: Package: qt5-qtwebkit-5.9.1-1.el7.x86_64 (epel)
           Requires: qt5-qtbase(x86-64) = 5.9.2
           Installed: qt5-qtbase-5.9.7-2.el7.x86_64 (@rhel7)
               qt5-qtbase(x86-64) = 5.9.7-2.el7
           Available: qt5-qtbase-5.6.1-3.el7.x86_64 (epel)
               qt5-qtbase(x86-64) = 5.6.1-3.el7
           Available: qt5-qtbase-5.6.1-10.el7.x86_64 (rhel7)
               qt5-qtbase(x86-64) = 5.6.1-10.el7
           Available: qt5-qtbase-5.6.2-1.el7.x86_64 (rhel7)
               qt5-qtbase(x86-64) = 5.6.2-1.el7
           Available: qt5-qtbase-5.9.2-3.el7.x86_64 (rhel7)
               qt5-qtbase(x86-64) = 5.9.2-3.el7
Error: Package: qt5-qtwebkit-5.9.1-1.el7.x86_64 (epel)
           Requires: qt5-qtdeclarative(x86-64) = 5.9.2
           Installed: qt5-qtdeclarative-5.9.7-1.el7.x86_64 (@rhel7)
               qt5-qtdeclarative(x86-64) = 5.9.7-1.el7
           Available: qt5-qtdeclarative-5.6.1-5.el7.x86_64 (epel)
               qt5-qtdeclarative(x86-64) = 5.6.1-5.el7
           Available: qt5-qtdeclarative-5.6.1-10.el7.x86_64 (rhel7)
               qt5-qtdeclarative(x86-64) = 5.6.1-10.el7
           Available: qt5-qtdeclarative-5.6.2-1.el7.x86_64 (rhel7)
               qt5-qtdeclarative(x86-64) = 5.6.2-1.el7
           Available: qt5-qtdeclarative-5.9.2-1.el7.x86_64 (rhel7)
               qt5-qtdeclarative(x86-64) = 5.9.2-1.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:

Versions match and the package installs.

Comment 1 Rex Dieter 2019-08-15 14:30:17 UTC
I think you mean rhel 7.7 ?  7.6 is fine as far as I'm aware.

Comment 2 Rex Dieter 2019-08-15 14:31:28 UTC
At least my 7.6 installs have only qt5-qtbase-5.9.2-3.el7

Comment 3 Thomas Klar 2019-08-15 14:34:34 UTC
Yes, indeed 7.7. Thanks.

Comment 4 Fedora Update System 2019-08-16 12:08:44 UTC
FEDORA-EPEL-2019-4ac0561239 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-4ac0561239

Comment 5 Fedora Update System 2019-08-17 00:07:51 UTC
qt5-qtwebkit-5.9.1-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-4ac0561239

Comment 6 Thomas Klar 2019-08-19 07:32:09 UTC
Thank you for building new packages so quickly. I'll test them within the next couple of days.

Comment 7 Thomas Klar 2019-08-21 08:41:37 UTC
I have just tested the two qtwebkit packages on a RHEL 7.7 workstation. The packages installed perfectly and the system works fine, so for my part, these can be pushed into the repo.

Thanks again.

Comment 8 Fedora Update System 2019-08-31 01:46:11 UTC
qt5-qtwebkit-5.9.1-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Travis Walden 2019-09-06 12:28:29 UTC
This update seems to have broken updates/installs on CentOS 7.6
Test installs on my RHEL 7.7 boxes are OK, though we are only really using it on CentOS.

# yum install qt5-qtwebkit-devel
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * epel-testing: mirror.steadfastnet.com
Resolving Dependencies
--> Running transaction check
---> Package qt5-qtwebkit-devel.x86_64 0:5.9.1-2.el7 will be installed
--> Processing Dependency: qt5-qtwebkit(x86-64) = 5.9.1-2.el7 for package: qt5-qtwebkit-devel-5.9.1-2.el7.x86_64
--> Processing Dependency: libQt5WebKit.so.5()(64bit) for package: qt5-qtwebkit-devel-5.9.1-2.el7.x86_64
--> Processing Dependency: libQt5WebKitWidgets.so.5()(64bit) for package: qt5-qtwebkit-devel-5.9.1-2.el7.x86_64
--> Running transaction check
---> Package qt5-qtwebkit.x86_64 0:5.9.1-2.el7 will be installed
--> Processing Dependency: qt5-qtbase(x86-64) = 5.9.7 for package: qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: qt5-qtdeclarative(x86-64) = 5.9.7 for package: qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Finished Dependency Resolution
Error: Package: qt5-qtwebkit-5.9.1-2.el7.x86_64 (epel)
           Requires: qt5-qtbase(x86-64) = 5.9.7
           Installed: qt5-qtbase-5.9.2-3.el7.x86_64 (@centos7-os)
               qt5-qtbase(x86-64) = 5.9.2-3.el7
Error: Package: qt5-qtwebkit-5.9.1-2.el7.x86_64 (epel)
           Requires: qt5-qtdeclarative(x86-64) = 5.9.7
           Installed: qt5-qtdeclarative-5.9.2-1.el7.x86_64 (@centos7-os)
               qt5-qtdeclarative(x86-64) = 5.9.2-1.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Note You need to log in before you can comment on or make changes to this bug.