Bug 174154 - After SIGHUP or graceful restart mpm_worker is unable to kill unused workers
After SIGHUP or graceful restart mpm_worker is unable to kill unused workers
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-25 04:32 EST by Piotr Gackiewicz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-20 04:51:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piotr Gackiewicz 2005-11-25 04:32:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
After reloading httpd by 'kill -HUP' (which is successfull, all workers are killed), unused workers (mpm_worker) are not beeing killed.
Free "slots" are being filed, logs are filled with:

[Fri Nov 25 10:19:36 2005] [warn] (32)Broken pipe: write pipe_of_death



Version-Release number of selected component (if applicable):
httpd-2.0.54-10.2

How reproducible:
Always

Steps to Reproduce:
1. kill -HUP `cat /var/run/httpd.pid`
2. watch status-table and error_log
  

Actual Results:  Unused httpd workers not being killed, 

Expected Results:  Unused httpd workers should be killed (their number should fall down to MaxSpareServers)

Additional info:
Comment 1 Piotr Gackiewicz 2005-11-25 04:39:57 EST
I made a mistake in report. The problem is with mpm_prefork, not mpm_worker.

Note You need to log in before you can comment on or make changes to this bug.