Bug 174158 - up2date errors reported do not help to resolve the problem
up2date errors reported do not help to resolve the problem
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2005-11-25 06:25 EST by Darren Lavender
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-19 14:50:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Darren Lavender 2005-11-25 06:25:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020 Firefox/0.10.1

Description of problem:
NOTE: This BZ is about up2date __NOT__ the specific example concerning 
serviceguard/pidentd mentioned below.  

When running 'up2date -u' the following 'unhelpful' message was produced:

Unresolvable chain of dependencies:
serviceguard-A.11.16.01-0                requires pidentd = 3.0.15sg

First impressions upon seeing this was that there was an issue with one or both of these packages, however both packages had been successfully installed by rpm with no errors or problems.

In order to figure out the problem further it was necessary to enable debug output from up2date, this then gave a few more clues:

Processing dependency (('serviceguard', 'A.11.16.03', '0'), ('pidentd',
'3.0.15sg'), 8, None, 0)

D: Dependencies: [('serviceguard', 'pidentd')]

D: Dep ['pidentd'] Fetched via: [['authd', '1.4.1', '1.rhel3', '', 'i386',
'40578', 'rhel-i386-as-3']]

D: Got back response: [['authd', '1.4.1', '1.rhel3', '', 'i386', '40578',

D: Already selected: ['authd', '1.4.1', '1.rhel3', '', 'i386', '40578',

This was still not entirely helpful but at least suggested that the two packages authd and pidentd should be scrutinised in more detail. Further investigation revealed that up2date had selected authd to be installed but existing package pidentd conflicts with it:

[root@bill up2date_client]# rpm -Vvv pidentd
D:  Requires: sed                                           YES (db provides)
D:  read h#      85 Header V3 DSA signature: OK, key ID db42a60e
D:  Requires: util-linux >= 2.11a-4                         YES (db provides)
D: Conflicts: authd                                         NO

The solution from here was simple, add authd to the package exclusion list, however getting to this point took many hours because up2date did not provide me with any better clues as to what the problem might be and I had to figure out how to obtain the additional debug info for myself.

In searching google I see many similar unresolved problems (different packages mentioned of course) reported by lots of people.  Whilst I don't necessarily have the expectation that up2date will say something as useful as:

"Cannot install authd because of conflict with installed package pidentd"

(But wouldn't that be great!!!)

It would be useful to at least mention something about the packages relating to the dependency issue, in this case authd.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
The problem above can probably be reproduced with any rpm combination that has a conflict with another package that up2date might want to install.

Actual Results:  The 'Unresolvable chain of dependencies' problem means that update -u will not complete successfully until the issue is resolved.

Expected Results:  Up2date should provide more informative and useful messages to help the user identify and resolve the problem. In an ideal world it would identify the problem and recommend a possible course of action, using the above example this might resemble:

Problem: "Cannot install/update the package authd (identified for update) because of a package conflict with the currently installed package pidentd".  

Action: "Remove currently installed package pidentd OR add the selected package authd to the up2date package exclusion list."

This approach could be extended to include other types of dependency related problems.

Additional info:
Comment 1 RHEL Product and Program Management 2007-10-19 14:50:35 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
For more information of the RHEL errata support policy, please visit:
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.