Bug 1741610 - overcloud create failed stack status shows CREATE_COMPLETE
Summary: overcloud create failed stack status shows CREATE_COMPLETE
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-heat
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Zane Bitter
QA Contact: bjacot
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-15 14:50 UTC by bjacot
Modified: 2019-08-15 15:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-15 15:23:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description bjacot 2019-08-15 14:50:40 UTC
Description of problem:
If a overcloud deployment fails the status is not reflected accurately in OpenStack stack list.  It will be logged as CREATE_COMPLETE 

Version-Release number of selected component (if applicable):
RHOS_TRUNK-15.0-RHEL-8-20190807.n.0

(undercloud) [stack@core-undercloud-0 ~]$ rpm -qa | grep openstack-heat
openstack-heat-engine-12.0.1-0.20190805120452.3476f1d.el8ost.noarch
openstack-heat-common-12.0.1-0.20190805120452.3476f1d.el8ost.noarch
openstack-heat-monolith-12.0.1-0.20190805120452.3476f1d.el8ost.noarch
openstack-heat-agents-1.8.1-0.20190523210450.1e15344.el8ost.noarch
openstack-heat-api-12.0.1-0.20190805120452.3476f1d.el8ost.noarch

How reproducible:
All the time

Steps to Reproduce:
1. install UC
2. Prep overcloud with some variable incorrect
3. deploy OC with the understanding it will fail

Actual results:
Overcloud configuration failed. then check openstack stack list.  Stack status will show create_complete

Expected results:
stack status should show create_Failed

Additional info:
no work around.

Output:
        "keystoneauth1.exceptions.connection.ConnectFailure: Unable to establish connection to http://172.25.0.111:5000/v3/auth/tokens: HTTPConnectionPool(host='172.25.0.111', port=5000): Max retries exceeded with url: /v3/auth/tokens (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f9e61c7ee48>: 
Overcloud configuration failed.
sys:1: ResourceWarning: unclosed <ssl.SSLSocket fd=8, family=AddressFamily.AF_INET, type=SocketKind.SOCK_STREAM, proto=6, laddr=('192.168.220.2', 35326), raddr=('192.168.220.2', 13808)>
sys:1: ResourceWarning: unclosed <ssl.SSLSocket fd=5, family=AddressFamily.AF_INET, type=SocketKind.SOCK_STREAM, proto=6, laddr=('192.168.220.2', 55224)>
sys:1: ResourceWarning: unclosed <ssl.SSLSocket fd=7, family=AddressFamily.AF_INET, type=SocketKind.SOCK_STREAM, proto=6, laddr=('192.168.220.2', 45626)>
sys:1: ResourceWarning: unclosed <ssl.SSLSocket fd=9, family=AddressFamily.AF_INET, type=SocketKind.SOCK_STREAM, proto=6, laddr=('192.168.220.2', 58334), raddr=('192.168.220.2', 13989)>
(undercloud) [stack@core-undercloud-0 ~]$ openstack stack list
+--------------------------------------+------------+----------------------------------+-----------------+----------------------+--------------+
| ID                                   | Stack Name | Project                          | Stack Status    | Creation Time        | Updated Time |
+--------------------------------------+------------+----------------------------------+-----------------+----------------------+--------------+
| 2c1a0bc3-ac77-4750-82f5-1f5bf2973472 | overcloud  | 902604f3884d49fc89b20547905c9f6d | CREATE_COMPLETE | 2019-08-15T11:54:04Z | None         |
+--------------------------------------+------------+----------------------------------+-----------------+----------------------+--------------+

Comment 1 bjacot 2019-08-15 15:23:30 UTC
was updated that the status is being tracked in two stages deploy and configure.  openstack overcloud status shows correctly.

(undercloud) [stack@core-undercloud-0 ~]$ openstack overcloud status
+-----------+---------------------+---------------------+-------------------+
| Plan Name |       Created       |       Updated       | Deployment Status |
+-----------+---------------------+---------------------+-------------------+
| overcloud | 2019-08-15 14:31:54 | 2019-08-15 14:31:54 |   DEPLOY_FAILED   |
+-----------+---------------------+---------------------+-------------------+


Note You need to log in before you can comment on or make changes to this bug.