Bug 174178 - Permission denied on boot when installed on reiserfs partition
Permission denied on boot when installed on reiserfs partition
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-25 08:34 EST by Simon Naunton
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-02 11:54:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Naunton 2005-11-25 08:34:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
I installed on a reiserfs3 partition. 

Accepted default other than partitions and not installing a boot manager.

Installation went ok.

On all subsequent boots I got permission denied errors and boot would hang when starting syslogd.

This was because selinux is set to enforcing by default and selinux does not like resiserfs.

A warning and/or setting selinux to disabled if a non ext? partition is selected for / during install would be nice.

Needed to boot using rescue cd or another installation of linux to turn selinux off.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install to a reiserfs 3 partition accepting defaults other than selecting the partition (and possibly not installing a boot mananger)
2. reboot
  

Actual Results:  Could not boot because syslogd was denied permissions.
Many other processes were denied permission during boot, but syslogd halted the boot.

Expected Results:  Normal boot.

Additional info:

I am asssuming that this has something to do with reiserfs because I know selinux does not like reiserfs.
Comment 1 Daniel Walsh 2006-01-02 11:54:22 EST
When the kernel resuports reiserfs this will start working.  Unfortunately we
don't support Reiserfs.

Note You need to log in before you can comment on or make changes to this bug.