Bug 174191 - Nm goes haywire when connected wlan turns on/off WEP
Nm goes haywire when connected wlan turns on/off WEP
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Depends On:
  Show dependency treegraph
Reported: 2005-11-25 12:18 EST by Kyrre Ness Sjøbæk
Modified: 2008-05-06 11:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 11:32:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Kyrre Ness Sjøbæk 2005-11-25 12:18:19 EST
Description of problem:
If you switch WEP on or off on an accesspoint that a laptop running
NetworkManager is connected to, NM does not understand what is going on (at
all), and has to be manually restarted/killed.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Connect to a wireless network using NetworkManager
2. Use the accesspoints web-interface (or otherwise) to turn on WEP
3. The wireless computer running NetworkManager looses all connections, display
false data, etc. until
"/etc/init.d/NetworkManager restart" is ran and NetworkManagerInfo is killed.
Actual results:

Expected results:

Additional info:
Comment 1 Christian Iseli 2007-01-22 06:40:36 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Comment 2 Kyrre Ness Sjøbæk 2007-02-17 06:02:16 EST
I do not exactly remember what happened back then, but i tried it again
(activating/deactivating WPA), and network manager (on fc6) wasn't happy with
it. Wether the problem would have sorted it self out if i had waited enough or
if it would had continued to pop up (pop under that is...) password dialogs when
i tried to connect, i don't know. But a restart solved it...
Comment 3 petrosyan 2008-03-09 19:10:47 EDT
Fedora Core 6 is no longer maintained. Can you reproduce this bug in Fedora 8?
Comment 4 Bug Zapper 2008-04-03 22:04:26 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 5 Bug Zapper 2008-05-06 11:32:19 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.