Bug 174196 - g-p-m crash
g-p-m crash
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
: 174648 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-25 14:33 EST by Havoc Pennington
Modified: 2013-03-13 00:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 14:42:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gnome-power-manager-rh#174196.patch (1.38 KB, patch)
2005-12-01 01:19 EST, Luke Macken
no flags Details | Diff
gnome-power-manager-rh#174196.patch (1.38 KB, patch)
2005-12-01 01:30 EST, Luke Macken
no flags Details | Diff
gnome-power-manager-rh#174196.patch (391 bytes, patch)
2005-12-01 01:57 EST, Luke Macken
no flags Details | Diff

  None (edit)
Description Havoc Pennington 2005-11-25 14:33:13 EST
Looks like a useless backtrace, but what I did was:
 - disabled notification icon
 - chose "power preferences" from System->Preferences
Not sure if it's reproduceable.


Backtrace was generated from '/usr/bin/gnome-power-manager'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
`shared object read from target memory' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208768064 (LWP 2562)]
0x00aa2402 in __kernel_vsyscall ()
#0  0x00aa2402 in __kernel_vsyscall ()
#1  0x00cc0043 in ?? () from /lib/libpthread.so.0
#2  0x008df4dd in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x06a8d93f in IA__g_type_check_instance_is_a (type_instance=0x92c4870, 
    iface_type=20) at gtype.c:3127
#5  0x06a76ea6 in IA__g_object_ref (_object=0x92c4870) at gobject.c:1627
#6  0x06d4dc17 in gtk_menu_window_event (window=0x92c3350, event=0x92109b4, 
    menu=0x92c4870) at gtkmenu.c:838
#7  0x06d49f50 in _gtk_marshal_BOOLEAN__BOXED (closure=0x92c4930, 
    return_value=0xbff625d0, n_param_values=2, param_values=0xbff626bc, 
    invocation_hint=0xbff625bc, marshal_data=0x6d4dbed) at gtkmarshalers.c:83
#8  0x06a74bd8 in IA__g_closure_invoke (closure=0x92c4930, 
    return_value=0xbff625d0, n_param_values=2, param_values=0xbff626bc, 
    invocation_hint=0xbff625bc) at gclosure.c:492
#9  0x06a82ff5 in signal_emit_unlocked_R (node=0x91b8c38, detail=0, 
    instance=0x92c3350, emission_return=0xbff6283c, 
    instance_and_params=0xbff626bc) at gsignal.c:2485
#10 0x06a84597 in IA__g_signal_emit_valist (instance=0x92c3350, signal_id=45, 
    detail=0, var_args=0xbff628c0 "Ø(ö¿´\t!\tP3,\tAÀâ\006P3,\tØI\033\t")
    at gsignal.c:2254
#11 0x06a84b93 in IA__g_signal_emit (instance=0x92c3350, signal_id=45, 
    detail=0) at gsignal.c:2288
#12 0x06e2bd53 in gtk_widget_event_internal (widget=0x92c3350, 
    event=0x92109b4) at gtkwidget.c:3638
#13 0x06d48af0 in IA__gtk_main_do_event (event=0x92109b4) at gtkmain.c:1384
#14 0x0700a77f in gdk_event_dispatch (source=0x91a7020, callback=0, 
    user_data=0x0) at gdkevents-x11.c:2291
#15 0x0021e810 in IA__g_main_context_dispatch (context=0x9186a30)
    at gmain.c:1934
#16 0x00221816 in g_main_context_iterate (context=0x9186a30, block=1, 
    dispatch=1, self=0x9183608) at gmain.c:2565
#17 0x00221b38 in IA__g_main_loop_run (loop=0x91856a8) at gmain.c:2769
#18 0x08054382 in ?? ()
#19 0x00b5a62f in __libc_start_main (main=0x8053e24, argc=1, 
    ubp_av=0xbff62b34, init=0x8054680, fini=0x80546dc, 
    rtld_fini=0x2c5bbd <_dl_fini>, stack_end=0xbff62b2c)
    at ../sysdeps/generic/libc-start.c:231
#20 0x0804b691 in ?? ()

Thread 1 (Thread -1208768064 (LWP 2562)):
#0  0x00aa2402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00cc0043 in ?? () from /lib/libpthread.so.0
No symbol table info available.
#2  0x008df4dd in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x06a8d93f in IA__g_type_check_instance_is_a (type_instance=0x92c4870, 
    iface_type=20) at gtype.c:3127
	node = (TypeNode *) 0x1c00
	iface = (TypeNode *) 0x91817f4
	check =
Comment 1 Richard Hughes 2005-11-26 05:21:29 EST
Hmm. Not seen this one before. I can't reproduce this my side. On a related
note, I don't think g-p-m has been updated to 0.3.0 in rawhide, which seems a
shame. I'm going to release 0.3.1 soon with some ideas from Havoc, and lots of
bugfixes from upstream.
Comment 3 Richard Hughes 2005-11-30 04:40:52 EST
0.3.1 is now in rawhide which should fix this.
Comment 4 Luke Macken 2005-11-30 22:14:22 EST
This is still happening to me using rawhide's gnome-power-manger-0.3.1-1

#0  0x005ab402 in __kernel_vsyscall ()
#1  0x008a86f0 in *__GI_raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:67
#2  0x008a9c68 in *__GI_abort () at ../sysdeps/generic/abort.c:88
#3  0x008dda30 in __libc_message (do_abort=Variable "do_abort" is not available.)
    at ../sysdeps/unix/sysv/linux/libc_fatal.c:170
#4  0x008e40ab in *__GI___libc_free (mem=0x804fca6) at malloc.c:5603
#5  0x00200334 in g_free () from /usr/lib/libglib-2.0.so.0
#6  0x0804d3cf in main (argc=1, argv=0xbfb8dc24) at gpm-prefs.c:99
#7  0x0089562f in __libc_start_main (main=0x804cfe5 <main>, argc=1,
    ubp_av=0xbfb8dc24, init=0x804ea1c <__libc_csu_init>,
    fini=0x804ea78 <__libc_csu_fini>, rtld_fini=0xa4abbd <_dl_fini>,
    stack_end=0xbfb8dc1c) at ../sysdeps/generic/libc-start.c:231
#8  0x08049c61 in _start ()
Comment 5 Luke Macken 2005-12-01 01:19:22 EST
Created attachment 121662 [details]
gnome-power-manager-rh#174196.patch

Patch to fix gnome-power-preferences explosion
Comment 6 Luke Macken 2005-12-01 01:30:25 EST
Created attachment 121663 [details]
gnome-power-manager-rh#174196.patch

don't free a null policy.
Comment 7 Luke Macken 2005-12-01 01:57:52 EST
Created attachment 121665 [details]
gnome-power-manager-rh#174196.patch

smaller patch
Comment 8 Richard Hughes 2005-12-01 04:47:44 EST
Ahh! I fixed this exact crasher in gpm-main before I released 0.3.1 -- I forgot
it applied to gpm-prefs too! The patch is correct, could you please roll it into
a new RPM as a patch and I'll apply it to CVS also. On a more serious note, this
means the gconf schema is not being applied (as I previously thought) even in
the new 0.3.1 RH RPM. To test this theory, does gconf-editor display policy text
for the /apps/gnome-power-manager keys? Also, as another test, if you do yum
remove gnome-power-manager && yum install gnome-power-manager to see whether the
gconf schema is installed correctly on a new install, rather than an upgrade.
The upstream RPM seems to apply the schema fine, it might be worth trying that
also. Many thanks.

Richard.
Comment 9 Bill Nottingham 2005-12-01 13:47:04 EST
*** Bug 174648 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.