Bug 174197 - gnome-ssh-askpass looks malformed and is stealing focus in an odd way
gnome-ssh-askpass looks malformed and is stealing focus in an odd way
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-25 14:40 EST by Jef Spaleta
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 05:40:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of gnome-ssh-askpass window showing odd layout (10.92 KB, image/png)
2005-11-25 14:40 EST, Jef Spaleta
no flags Details

  None (edit)
Description Jef Spaleta 2005-11-25 14:40:08 EST
Description of problem:
openssh-askpass-4.2p1-9

1)the password entry dialog window as a very small text entry area
and a large status bar next to it. Is this intentional? Screenshot of window
attached.


2)While the password dialog is open I can't interact with other applications
correctly. 

For example I can focus gnome-terminal, but I can't open any menus and I can't
enter text into the terminal. Xchat is the same.

But firefox I can focus and interact with menus without a problem, but the
askpass dialog steals any text entry.
Comment 1 Jef Spaleta 2005-11-25 14:40:09 EST
Created attachment 121493 [details]
Screenshot of gnome-ssh-askpass window showing odd layout
Comment 2 Tomas Mraz 2005-11-28 05:40:26 EST
1) That's intentional. The password entry is small so the number of password
character's is obscured. The progres bar provides the feedback for keypresses.

2) The keyboard grab is intentional as well so no other X client is
eavesdropping on the keys pressed. You can use GNOME_SSH_ASKPASS_GRAB_POINTER=1
to grab mouse pointer as well so there is no interaction with other windows
possible at all. It would be more consistent behaviour however it would prevent
you from copy+paste passwords from other windows if you didn't do the copy
before the dialog appears.
Comment 3 Jef Spaleta 2005-11-28 09:54:50 EST
1) I see the point. But how the UI was implemented feels unnerving it quite
frankly looks broken to my untrained eye.  I can't pinpoint it, it just feels
out of proportion. I guess because the text box no longer registered instantly
as a text box since I'm so use to seeing text boxes being more rectangular than
square. At first glance it looks like a checkbox almost.

1a)reorganize the dialog a little and provide visible text to indicated that the
textbox is a textbox.

Enter password: [ ]
[progress bar] 

1b) Any chance that a clear password button could be added?

2) Can this be made so that the dialog keeps focus as well by default?  What
felt odd was the fact that I could go to other windows and interact with the
window in an half-ass sort of way.  Firefox let me interact with its menus for
example..but no text entry.  I could click on gnome-terminal's menu and the menu
was blank. It would be much cleaner experience if the dialog grab not only text
entry but all focus so I couldn't interact with other windows at all.  The way
it works now already breaks some important UI consistency with regard to copy
and paste. I can't use the menu entries in gnome-terminal to get to the copy
command.

2a)add paste button or context menu with paste/clear?
2b)anyway the dialog could provide a tool tip or some other notice telling you
that you have entered a protected state?

Note You need to log in before you can comment on or make changes to this bug.