This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 174203 - Apple Cinema Display 20" not properly detected (driver nv)
Apple Cinema Display 20" not properly detected (driver nv)
Status: CLOSED DUPLICATE of bug 174206
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-25 15:55 EST by Jurgen Kramer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-25 16:43:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg.0.log (39.23 KB, text/plain)
2005-11-25 15:55 EST, Jurgen Kramer
no flags Details

  None (edit)
Description Jurgen Kramer 2005-11-25 15:55:51 EST
Description of problem:


Version-Release number of selected component (if applicable):
X Window System Version 6.99.99.902 (7.0.0 RC 2)

How reproducible:
Alway

Steps to Reproduce:
1. Hand select Apple Cinema Display 20" from firstboot (not detected
automatically during install)
2. Set display to max res. 1680x1050 24bits
3. 
  
Actual results:
X shows black bars on the right and left instead of proper full screen picture

Expected results:
Proper full screen picture

Additional info:
Videocard GeForce 6600 GT (PCI-E)

From Xorg.0.log:
(--) NV(0): DDC detected a DFP:
(II) NV(0): Manufacturer: APP  Model: 921d  Serial#: 50201046
(II) NV(0): Year: 2004  Week: 46
(II) NV(0): EDID Version: 1.3
(II) NV(0): Digital Display Input
(II) NV(0): Max H-Image Size [cm]: horiz.: 43  vert.: 27
(II) NV(0): Gamma: 2.20
(II) NV(0): DPMS capabilities: Off; RGB/Color Display
(II) NV(0): Default color space is primary color space
(II) NV(0): First detailed timing is preferred mode
(II) NV(0): redX: 0.640 redY: 0.340   greenX: 0.295 greenY: 0.610
(II) NV(0): blueX: 0.145 blueY: 0.070   whiteX: 0.312 whiteY: 0.329
(II) NV(0): Manufacturer's mask: 0
(II) NV(0): Supported Future Video Modes:
(II) NV(0): #0: hsize: 1680  vsize 1050  refresh: 60  vid: 179
(II) NV(0): Supported additional Video Mode:
(II) NV(0): clock: 119.0 MHz   Image Size:  433 x 270 mm
(II) NV(0): h_active: 1680  h_sync: 1728  h_sync_end 1760 h_blank_end 1840
h_border: 0
(II) NV(0): v_active: 1050  v_sync: 1053  v_sync_end 1059 v_blanking: 1080
v_border: 0
(II) NV(0): Monitor name: Cinema Displa
(II) NV(0): Monitor name: y
(II) NV(0): Number of EDID sections to follow: 1
(II) NV(0): Probing for EDID on I2C bus B...
(II) NV(0): I2C device "DDC:ddc2" registered at address 0xA0.
(II) NV(0): I2C device "DDC:ddc2" removed.
(II) NV(0):   ... none found
(--) NV(0): CRTC 0 is currently programmed for DFP
(II) NV(0): Using DFP on CRTC 0
(--) NV(0): Panel size is 1680 x 1050
(II) NV(0): Panel is TMDS
(--) NV(0): VideoRAM: 131072 kBytes
(==) NV(0): Using gamma correction (1.0, 1.0, 1.0)
(II) NV(0): Monitor0: Using default hsync range of 64.67-67.41 kHz
(II) NV(0): Monitor0: Using default vrefresh range of 59.88-60.00 Hz
(II) NV(0): Clock range:  12.00 to 400.00 MHz

Which results in the following xorg.conf (driver nv):
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Apple Cinema Display 20 LCD"
        HorizSync    30.0 - 75.0
        VertRefresh  60.0 - 60.0

Horizontal refresh is not correct, it should be:

: Frequency information for DFP-1:
HorizSync   : 64.000-65.000 kHz
VertRefresh : 60.000 Hz
Comment 1 Jurgen Kramer 2005-11-25 15:55:52 EST
Created attachment 121494 [details]
Xorg.0.log
Comment 2 Marius Andreiana 2005-11-25 16:43:17 EST
Thanks Jurgen for this bug report, but there's no need to fill it twice. I'll
keep the one in xorg-x11-drivers

*** This bug has been marked as a duplicate of 174206 ***

Note You need to log in before you can comment on or make changes to this bug.