Bug 174230 - Missing Dependency: libXXX.so.1 is needed by package seahorse
Missing Dependency: libXXX.so.1 is needed by package seahorse
Product: Fedora
Classification: Fedora
Component: seahorse (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
Depends On:
Blocks: FE5Target
  Show dependency treegraph
Reported: 2005-11-26 04:37 EST by Marius Andreiana
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-23 14:19:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Marius Andreiana 2005-11-26 04:37:30 EST
yum -y install seahorse on FC5t1 gives

Error: Missing Dependency: libpixman.so.1 is needed by package seahorse
Error: Missing Dependency: libcairo.so.1 is needed by package seahorse

It needs a rebuild?

Comment 1 Andy Burns 2006-01-30 16:12:08 EST
Apparently still needs one post FC5T2 :-(
Comment 2 Andy Burns 2006-01-31 14:56:58 EST
just tried an 

rpmbuild --recompile seahorse-0.7.9-1.fc5.src.rpm

to see if a simple rebuild is all that this requires
I believe I have all deps installed, but it fails with

checking for gpgme-config... /usr/bin/gpgme-config
checking for GPGME - version >= 1.0.0... configure: error: GPGME 1.0.0 or later
error: Bad exit status from /var/tmp/rpm-tmp.77787 (%build)

however /usr/bin/gpgme-config --version does report 1.1.0 is installed

Comment 3 John Thacker 2006-02-22 16:40:02 EST
It's a bug in the configure script.  The configure script incorrectly tests to
see if the minor version of gpgme is equal to that of 1.0.0, the minimum
required version, rather than just greater than or equal to:

on line 97:
if test "$minor" -eq "$req_minor"; then

should be:
if test "$minor" -ge "$req_minor"; then

No other changes are necessary-- if you look at the CVS sources for seahorse,
the bug was fixed immediately after the 0.8 release, even on the same day. 
(Presumably after people downloaded it and found that it wouldn't work with
gpgme 1.1.0)

It's pretty trivial to whip up a patch.
Comment 4 John Thacker 2006-02-22 16:52:34 EST
Oh, also note that the GEdit plugin for seahorse-0.8 won't work with gedit-2.14.
 It's fixed in CVS, in the hopefully-soon 0.8.1.  So we can either compile for
now with --disable-gedit or wait and hope that 0.8.1 will be released.
Comment 5 Seth Vidal 2006-02-22 20:43:08 EST
Thanks - I already have a package with the patch from seahorse cvs for the
configure problem and gedit disabled. I was waiting for as long as I could in
hope that 0.8.1 would be available.
Comment 6 Seth Vidal 2006-02-23 14:19:03 EST
It should be built today and in fedora extras development repo at the next push.

Note You need to log in before you can comment on or make changes to this bug.