Bug 174238 - Bad: toshiba_acpi does not enable bluetooth device
Bad: toshiba_acpi does not enable bluetooth device
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
http://www.cwrose.de/toshiba/s5200.ht...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-26 05:30 EST by Rui Carmo
Modified: 2015-01-04 17:23 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-26 12:58:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rui Carmo 2005-11-26 05:30:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The built-in toshiba_acpi module, despite providing adequate support for Toshiba fnfx functionality, does not enable Bluetooth support (i.e., there is no /proc/acpi/toshiba/bluetooth).

The URLs below have a working patch (as well as a completely new version of the toshiba_acpi.c file).

http://www.cwrose.de/toshiba/s5200.html#bluetooth
http://nicolas.bettenburg.free.fr/linux/files/toshiba_acpi.c

Version-Release number of selected component (if applicable):
kernel-2.6.14-1.1637_FC4

How reproducible:
Always

Steps to Reproduce:
1. Install FC4
2. Install fnfx, modprobe toshiba_acpi
3. Verify that there is no /proc/acpi/toshiba/bluetooth (even though fnfx is able to control display brightness, etc.)

Additional info:
Comment 1 Dave Jones 2005-11-26 12:58:53 EST
please tell the developers of this code to push their changes upstream.

Fedora stays as close to the mainline kernel as possible. If we carried updates
to various drivers, we'd end up with something completely unmaintainable, and
impossible to convince upstream developers to look at.
Comment 2 Rui Carmo 2005-11-27 12:35:34 EST
I suppose this is not a "various driver", then...

http://cvs.fedora.redhat.com/viewcvs/devel/kernel/linux-2.6-acpi-thinkpad-c2c3.patch?rev=1.1&view=log
Comment 3 Rui Carmo 2005-11-27 14:26:08 EST
Nevermind, I now know what the IBM stuff is for.

In the meantime, I documented my toshiba_acpi modifications at:
http://the.taoofmac.com/space/HOWTO/Enable%20Toshiba%20Bluetooth%20Support%20In%20Fedora%20Core%204

If you'd be so kind as to drop me a line telling me whom to contact or how to go
about doing it, I'll gladly get it into kernel.org...
Comment 4 Dave Jones 2005-11-28 14:58:03 EST
that thinkpad patch got merged because without it, it prevents installation.
feature requests go upstream.

The upstream maintainer of Toshiba_ACPI is John Belmonte, so send a mail to him at
toshiba_acpi@memebeam.org and hopefully he'll merge your changes in for a future
upstream kernel release.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.