Bug 174241 - Remote host breaks connection
Remote host breaks connection
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: telnet (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-26 06:13 EST by Nickolay V. Shmyrev
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 06:43:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tcpdump of working patched version (32.00 KB, text/plain)
2005-11-26 06:13 EST, Nickolay V. Shmyrev
no flags Details
Original broken tcpdump (40.00 KB, text/plain)
2005-11-26 06:14 EST, Nickolay V. Shmyrev
no flags Details

  None (edit)
Description Nickolay V. Shmyrev 2005-11-26 06:13:18 EST
Hi

Sorry, probably it's not a telnet bug, but let me ask since it seems redhat
distributes it's own version of telnet. I can't login to the host 217.21.95.36
with telnet. Remote host breaks connection a second after "Login:" prompt appears.
To solve this problem, I've managed to comment line 2170 in telnet.c like that:

// send_will(TELOPT_LINEMODE, 1);

Is it a bug in remote implementation or other issue of telnet protocol?
Comment 1 Nickolay V. Shmyrev 2005-11-26 06:13:18 EST
Created attachment 121501 [details]
tcpdump of working patched version
Comment 2 Nickolay V. Shmyrev 2005-11-26 06:14:24 EST
Created attachment 121502 [details]
Original broken tcpdump
Comment 3 Rahul Sundaram 2006-02-20 05:40:21 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 4 Harald Hoyer 2006-09-29 06:43:17 EDT
well, telnet wants to negotiate with the remote host, if LINEMODE can be used.
Seems like 217.21.95.36 does not like that negotiation. So the bug is on the
remote site. 

$ man telnet
...
       Once  a  connection  has been opened, telnet will attempt to enable the
       TELNET LINEMODE option.  If this fails, then telnet will revert to  one
       of  two  input  modes:  either ‘‘character at a time’’ or ‘‘old line by
       line,’’ depending on what the remote system supports.
...

Note You need to log in before you can comment on or make changes to this bug.