Bug 174245 - directfb upgrade breaks livna packages
directfb upgrade breaks livna packages
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: directfb (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-26 07:55 EST by Alex Lancaster
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-27 13:22:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2005-11-26 07:55:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Galeon/1.3.21

Description of problem:
The recently upgraded directfb packages breaks the dependencies for many livna packages, see:

http://bugzilla.livna.org/show_bug.cgi?id=672

This is very bad breakage, using smart here is what happens (yum won't even handle any kind of upgrade):

# sudo smart upgrade
Loading cache...
Updating cache...               ######################################## [100%]

Computing transaction...

Upgrading packages (1):
  directfb-0.9.24-4.fc4@i386

Downgrading packages (1):
  mplayer-1.0-0.lvn.0.22.pre7.4@i386

Installed packages (1):
  sysfsutils-1.2.0-4@i386

Removed packages (7):
  dvdstyler-1:1.4-0.lvn.3.4@i386
  kaffeine-0.7.1-0.lvn.3.4@i386
  mplayer-gui-1.0-0.lvn.0.28.pre7try2.4@i386
  mplayer-mencoder-1.0-0.lvn.0.28.pre7try2.4@i386
  xine-0.99.4-0.lvn.3.4@i386
  xine-lib-1.1.0-0.lvn.6.4@i386
  xine-lib-devel-1.1.0-0.lvn.6.4@i386

5.8MB of package files are needed. 25.8MB will be freed.

Confirm changes? (Y/n): n

Although strictly speaking, this is not a bug in the package itself, given that this is a foundational library and many livna packages depend on it, there should be better co-ordination with the livna developers when upgrading it, so that rebuilt packages can be made available almost simultaneously with the Extras package.   I also realise that although livna is not officially associated with Fedora Extras (FE) in anyway, unofficially it has become the repository that most closely tracks FE and attempts to co-ordinate with.

Version-Release number of selected component (if applicable):
0.9.24-4.fc4

How reproducible:
Always

Steps to Reproduce:
1. yum upgrade

  

Actual Results:  See: 
http://bugzilla.livna.org/show_bug.cgi?id=672


Expected Results:  Other livna packages should have also been upgraded to use the new library.

Additional info:

With foundational libraries this is likely to become a major problem if there isn't some (semi-)automated way to at least notify the livna developers of a major library upgrade so they can rebuild their packages.
Comment 1 Alex Lancaster 2005-11-26 08:08:58 EST
More breakage, just FYI for tracking:

http://bugzilla.livna.org/show_bug.cgi?id=669
http://bugzilla.livna.org/show_bug.cgi?id=670
Comment 2 Alex Lancaster 2005-11-26 08:10:10 EST
Changing severity to "enhancement", because it is really an enhancement in the
package process.
Comment 3 Hans de Goede 2005-11-27 13:22:29 EST
Hmm,

I know livna would need some package rebuilds but I didn't expect a breakage in
between, to solve stuff like this extras keeps older versions of lib packages
around.

You could have worked around this by just adding --exclude=directfb to your yum
update cmdline.

And you can fix things by reinstalling the still available old directfb and use
--exclude=directfb untill livna is in sync.

Anyways sorry for the inconvience closing as not a bug, since this is not a bug.

If its a bug anywhere its a bug in smart. yum did the right thing iow asked the
user to fix it, although some kinda interactive fix mode which would allow the
user to choose between the smart way or the yum --exclude way would be nice.
Comment 4 Hans de Goede 2005-11-27 13:25:24 EST
p.s.

My previous statement may sound a bit more harsh then intended I will do my best
with future updates to notify livna in advance, that is ifcourse a very
reasonable request.
Comment 5 Alex Lancaster 2005-11-28 00:07:38 EST
(In reply to comment #3)
> Hmm,
> 
> I know livna would need some package rebuilds but I didn't expect a breakage in
> between, to solve stuff like this extras keeps older versions of lib packages
> around.
> 
> You could have worked around this by just adding --exclude=directfb to your yum
> update cmdline.

I am aware of all those workarounds.  My point in opening a bug was to raise
awareness of the inter-repository rebuilds and co-ordination issues.  The
mailing list posts on fedora-extras-list also help that.  In general it's
probably a good idea for packages which livna depends on to be better
co-ordinated between FE and livna for library upgrades which change the lib*.so
dependencies.  PS.  This also pertains for Core and Extra upgrades (e.g. mozilla
updates from Core constantly break galeon in Extras).

Note You need to log in before you can comment on or make changes to this bug.