Bug 17425 - When Installing err: /boot partition too big
When Installing err: /boot partition too big
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-12 09:53 EDT by Darrel Anthony
Modified: 2007-03-26 23:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-12 10:01:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Darrel Anthony 2000-09-12 09:53:52 EDT
I am currently running Windows 98 on a PIII 450Mhz machine with 128Mb RAM 
12Gb hard drive, etc.
I have partitioned 75% of my harddisk as FAT32 and installed Win98 on that 
portion, leaving roughly 3Gb for Linux (plenty?).

I am trying to install Linux 6.2 (boxed-set) on my machine. I have tried 
the workstation option, but it insists on me manually partitioning the 
hard-disk, as does the custom option, although that's supposed to.

When i try and add the 16Mb /boot partition it wont let me continue - it 
produces a messagebox saying that the boot partition is too big; it's only 
16Mb, definatly. All i want to add is a 16Mb /boot partition, a 128Mb swap 
partition and just fill the rest of the disk with the /root partition.

I tried deleting the Windows 98 (FAT32) partition and adding the /boot 
partition again, and it worked fine! However, i want to be able to use 
both OS's. Why does it say that the /boot partition is too big when the 
primary partition is the 75% FAT32, but works fine when i remove it?

I also tried installing linux first using 3Gb and then installing Win98 on 
the secondary partition (It would only let me make the FAT32 a 4Gb 
partition as it was secondary). Afterwards, typing "linux" from the LILO 
boots linux, but when typing "dos" from LILO i got the 0x00 error message 
so i cant load Win98 that way either.

I'm out of ideas now :o) Can you help?
Comment 1 Michael Fulbright 2000-09-13 12:13:48 EDT
The error message is somewhat misleading.  The problem is most likely that when
you had the Windows
partition on your drive that the only available free space on the drive to
allocate the /boot partition was
on a drive cylinder above the 1024 limit that BIOS imposes for partitions you
can boot off of. When you
deleted Windows then the /boot partition could be allocated under the 1024
cylinder limit and it worked.

Hopefully in the future we will be able to boot from cylinders greater than
1024.

Note You need to log in before you can comment on or make changes to this bug.