Bug 174252 - mail goes to root@localhost.localdomain
mail goes to root@localhost.localdomain
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: smartmontools (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-11-26 10:42 EST by Pierre Ossman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: smartmontools-5.33-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-16 17:35:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pierre Ossman 2005-11-26 10:42:42 EST
The script that generates smartd.conf uses the mail address
root@localhost.localdomain. Since every (more or less) other tool sends their
mail to just 'root', these messages tend to be lost using certain setups.

My system directs the mail to a central root account by having domain-less
addresses routed to a complete non-local address. In order to catch these
localhost.localdomain addresses I had to add a special alias for them.

Please change the script so it uses just 'root' (or gets the machine's domain
name if you insist on a complete address). The current situation is terribly
annoying and repeatedly causes errors.
Comment 1 Tomas Mraz 2005-11-28 05:16:43 EST
Is root@localhost (that's the way it is in the latest FC development package)
good enough?
Comment 2 Pierre Ossman 2005-11-28 05:35:11 EST
No, the name needs to be unqualified. The mailserver completes unqualified to
user@mydomain.com and sends it through normal processing.

root@localhost is considered complete so it is scheduled for local delivery
instead of being handed of to the central mail server (unless an alias is added).

A default crontab has 'MAILTO=root', logwatch has 'MailTo = root' and mdadm has
'MAILADDR root', so smartmontools should probably fall in line. :)

Note You need to log in before you can comment on or make changes to this bug.