Bug 1742611 - libbsd-0.11.7 is available [NEEDINFO]
Summary: libbsd-0.11.7 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libbsd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Eric Smith
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 2094582
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-16 19:43 UTC by Upstream Release Monitoring
Modified: 2022-12-20 02:23 UTC (History)
4 users (show)

Fixed In Version: libbsd-0.11.7-2.el8 libbsd-0.11.7-2.el7 libbsd-0.11.7-2.fc37 libbsd-0.11.7-2.el9 libbsd-0.11.7-2.fc36
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-12-20 00:34:49 UTC
Type: ---
redhat-bugzilla: needinfo? (spacewar)
redhat-bugzilla: needinfo? (spacewar)


Attachments (Terms of Use)
[patch] Update to 0.10.0 (#1742611) (1.13 KB, patch)
2019-08-16 19:43 UTC, Upstream Release Monitoring
no flags Details | Diff
[patch] Update to 0.11.2 (#1742611) (1.13 KB, patch)
2021-02-08 04:18 UTC, Upstream Release Monitoring
no flags Details | Diff
[patch] Update to 0.11.3 (#1742611) (1.13 KB, patch)
2021-02-09 06:04 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 0.11.4 (#1742611) (1.13 KB, patch)
2022-01-22 23:02 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 0.11.5 (#1742611) (1.13 KB, patch)
2022-01-25 01:19 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 0.11.6 (#1742611) (1.13 KB, patch)
2022-03-30 21:38 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 0.11.7 (#1742611) (1.13 KB, patch)
2022-10-06 03:16 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2019-08-16 19:43:00 UTC
Latest upstream release: 0.10.0
Current version/release in rawhide: 0.9.1-4.fc31
URL: http://libbsd.freedesktop.org/releases/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/1567/

Comment 1 Upstream Release Monitoring 2019-08-16 19:43:04 UTC
Created attachment 1604997 [details]
[patch] Update to 0.10.0 (#1742611)

Comment 2 Upstream Release Monitoring 2019-08-16 20:28:06 UTC
the-new-hotness/release-monitoring.org's scratch build of libbsd-0.10.0-1.fc29.src.rpm for rawhide completed http://koji.fedoraproject.org/koji/taskinfo?taskID=37083722

Comment 3 Upstream Release Monitoring 2021-02-07 01:15:45 UTC
Latest upstream release: 0.11.1
Current version/release in rawhide: 0.10.0-7.fc34
URL: http://libbsd.freedesktop.org/releases/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/1567/

Comment 4 Upstream Release Monitoring 2021-02-07 01:15:50 UTC
An unexpected error occurred while creating the scratch build and has been automatically reported. Sorry!

Comment 5 Upstream Release Monitoring 2021-02-08 04:18:19 UTC
Latest upstream release: 0.11.2
Current version/release in rawhide: 0.10.0-7.fc34
URL: http://libbsd.freedesktop.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/1567/

Comment 6 Upstream Release Monitoring 2021-02-08 04:18:23 UTC
Created attachment 1755603 [details]
[patch] Update to 0.11.2 (#1742611)

Comment 7 Upstream Release Monitoring 2021-02-08 04:22:59 UTC
the-new-hotness/release-monitoring.org's scratch build of libbsd-0.11.2-1.fc32.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=61568745

Comment 8 Upstream Release Monitoring 2021-02-09 06:04:24 UTC
Latest upstream release: 0.11.3
Current version/release in rawhide: 0.10.0-7.fc34
URL: http://libbsd.freedesktop.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/1567/

Comment 9 Upstream Release Monitoring 2021-02-09 06:04:28 UTC
Created attachment 1755847 [details]
[patch] Update to 0.11.3 (#1742611)

Comment 10 Upstream Release Monitoring 2021-02-09 06:09:02 UTC
the-new-hotness/release-monitoring.org's scratch build of libbsd-0.11.3-1.fc32.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=61642496

Comment 11 Upstream Release Monitoring 2022-01-22 23:02:29 UTC
Latest upstream release: 0.11.4
Current version/release in rawhide: 0.10.0-8.fc35
URL: http://libbsd.freedesktop.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/1567/

Comment 12 Upstream Release Monitoring 2022-01-22 23:02:34 UTC
Created attachment 1852796 [details]
Update to 0.11.4 (#1742611)

Comment 13 Upstream Release Monitoring 2022-01-22 23:06:52 UTC
the-new-hotness/release-monitoring.org's scratch build of libbsd-0.11.4-1.fc34.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=81688064

Comment 14 Upstream Release Monitoring 2022-01-25 01:18:57 UTC
Latest upstream release: 0.11.5
Current version/release in rawhide: 0.10.0-8.fc35
URL: http://libbsd.freedesktop.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/1567/

Comment 15 Upstream Release Monitoring 2022-01-25 01:19:08 UTC
Created attachment 1853221 [details]
Update to 0.11.5 (#1742611)

Comment 16 Upstream Release Monitoring 2022-01-25 03:25:41 UTC
the-new-hotness/release-monitoring.org's scratch build of libbsd-0.11.5-1.fc34.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=81801539

Comment 17 Xose Vazquez Perez 2022-03-13 12:52:13 UTC
(In reply to Upstream Release Monitoring from comment #14)

> Latest upstream release: 0.11.5
> Current version/release in rawhide: 0.10.0-8.fc35
> URL: http://libbsd.freedesktop.org
> Based on the information from Anitya: https://release-monitoring.org/project/1567/

Could it be update? Thanks.

libbsd 0.11.1:
This release, which subsumes the 0.11.0 announcement, includes:
 - Export strnvisx() function.
 - New recallocarray() and freezero() from OpenBSD.
 - New pwcache module from OpenBSD.
 - New timespec(3bsd) man page alias to timeval(3bsd).
 - New progname implementation for Windows.
 - New LIBBSD_VIS_OPENBSD selection macro.
 - Switch from embedded hashing function implementations to use libmd.
 - Various man pages cleanups.
 - Various portability fixes.
 - Various memory leak fixes.

libbsd 0.11.2:
    - Update <sys/queue.h> from FreeBSD.
    - Import some closefrom() changes from sudo.
    - Make closefrom() use close_range() syscall on Linux when available.
    - Update libbsd(7) man page with updates in 0.11.0.

libbsd 0.11.3:
  - Rework of the libmd wrapping code to not require users to explicitly
    link against libmd.
  - Various build system fixes.
  - Various portability fixes.

libbsd 0.11.4:
  - Further rework of the libmd wrapping code, to simplify it again, and
    make it work even when we do not need SHA-2 functions.
  - Fix builds with LTO.
  - Various build system fixes.
  - Various portability fixes.
  - Various documentation fixes.

libbsd 0.11.5:
  - Build system and test suite regression fixes.
  - Documentation on how to build the project.

Comment 18 Upstream Release Monitoring 2022-03-30 21:38:31 UTC
Latest upstream release: 0.11.6
Current version/release in rawhide: 0.10.0-9.fc36
URL: http://libbsd.freedesktop.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/1567/

Comment 19 Upstream Release Monitoring 2022-03-30 21:38:37 UTC
Created attachment 1869571 [details]
Update to 0.11.6 (#1742611)

Comment 20 Upstream Release Monitoring 2022-03-30 21:43:52 UTC
the-new-hotness/release-monitoring.org's scratch build of libbsd-0.11.6-1.fc34.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=84948266

Comment 21 Robert Scheck 2022-05-30 18:41:26 UTC
Is there finally any chance for getting libbsd updated to 0.11.x on *all* active Fedora and EPEL branches? Signify v31 actually depends on libbsd >= 0.11.0, see https://github.com/aperezdc/signify/issues/35 for details.

Comment 22 Robert Scheck 2022-06-07 23:34:48 UTC
While looking into this update myself, I noticed that libbsd >= 0.11.0 depends on libmd, which I now submitted for a package review via bug #2094582.

Comment 23 Robert Scheck 2022-09-14 23:13:12 UTC
Since libmd is on the way into the repositories, I had a look to the libbsd update in detail.

My current proposal is https://src.fedoraproject.org/rpms/libbsd/pull-request/1

Merging should likely wait for https://gitlab.com/fedora/legal/fedora-license-data/-/issues/71

In general I would like to see all active Fedora and EPEL branches shipping 0.11.6 for signify. According to my understanding, there should be no ABI or API breakage.

Eric, please review and/or provide feedback.

Comment 24 Upstream Release Monitoring 2022-10-06 03:16:37 UTC
Releases retrieved: 0.11.7
Upstream release that is considered latest: 0.11.7
Current version/release in rawhide: 0.10.0-10.fc37
URL: http://libbsd.freedesktop.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/1567/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/libbsd

Comment 25 Upstream Release Monitoring 2022-10-06 03:16:42 UTC
Created attachment 1916346 [details]
Update to 0.11.7 (#1742611)

Comment 26 Upstream Release Monitoring 2022-10-06 03:22:22 UTC
the-new-hotness/release-monitoring.org's scratch build of libbsd-0.11.7-1.fc36.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=92684884

Comment 27 Fedora Update System 2022-11-23 23:30:00 UTC
FEDORA-2022-c3b0dfa797 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-c3b0dfa797

Comment 28 Fedora Update System 2022-11-23 23:30:02 UTC
FEDORA-2022-19aa7f5efb has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-19aa7f5efb

Comment 29 Fedora Update System 2022-11-23 23:30:03 UTC
FEDORA-2022-32e69d01a9 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-32e69d01a9

Comment 30 Fedora Update System 2022-11-23 23:32:40 UTC
FEDORA-EPEL-2022-08012668ea has been submitted as an update to Fedora EPEL 8. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-08012668ea

Comment 31 Fedora Update System 2022-11-24 00:01:29 UTC
FEDORA-EPEL-2022-10049c7b14 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-10049c7b14

Comment 32 Fedora Update System 2022-11-24 02:35:35 UTC
FEDORA-2022-c3b0dfa797 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-c3b0dfa797`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-c3b0dfa797

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 33 Fedora Update System 2022-11-24 02:56:23 UTC
FEDORA-2022-19aa7f5efb has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-19aa7f5efb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-19aa7f5efb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 34 Fedora Update System 2022-11-24 03:00:58 UTC
FEDORA-2022-32e69d01a9 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-32e69d01a9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-32e69d01a9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 35 Fedora Update System 2022-11-24 03:18:30 UTC
FEDORA-EPEL-2022-08012668ea has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-08012668ea

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 36 Fedora Update System 2022-11-24 03:26:17 UTC
FEDORA-EPEL-2022-10049c7b14 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-10049c7b14

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 37 Fedora Update System 2022-11-24 03:41:54 UTC
FEDORA-EPEL-2022-13cfdabccc has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-13cfdabccc

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 38 Fedora Update System 2022-12-05 01:54:43 UTC
FEDORA-EPEL-2022-10049c7b14 has been pushed to the Fedora EPEL 7 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-10049c7b14

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 39 Fedora Update System 2022-12-05 01:55:36 UTC
FEDORA-EPEL-2022-08012668ea has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-08012668ea

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 40 Fedora Update System 2022-12-05 02:33:25 UTC
FEDORA-EPEL-2022-13cfdabccc has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2022-13cfdabccc

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 41 Fedora Update System 2022-12-05 03:19:36 UTC
FEDORA-2022-c3b0dfa797 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-c3b0dfa797`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-c3b0dfa797

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 42 Fedora Update System 2022-12-05 03:36:36 UTC
FEDORA-2022-19aa7f5efb has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-19aa7f5efb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-19aa7f5efb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 43 Fedora Update System 2022-12-05 03:42:47 UTC
FEDORA-2022-32e69d01a9 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-32e69d01a9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-32e69d01a9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 44 Fedora Update System 2022-12-20 00:34:49 UTC
FEDORA-EPEL-2022-08012668ea has been pushed to the Fedora EPEL 8 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 45 Fedora Update System 2022-12-20 00:37:22 UTC
FEDORA-EPEL-2022-10049c7b14 has been pushed to the Fedora EPEL 7 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 46 Fedora Update System 2022-12-20 01:27:58 UTC
FEDORA-2022-c3b0dfa797 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 47 Fedora Update System 2022-12-20 01:56:30 UTC
FEDORA-EPEL-2022-13cfdabccc has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 48 Fedora Update System 2022-12-20 02:23:56 UTC
FEDORA-2022-19aa7f5efb has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.