Bug 174262 - keychain breaks scp, opt-in inconsistency with zsh, 2.6.1 available
Summary: keychain breaks scp, opt-in inconsistency with zsh, 2.6.1 available
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: keychain   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Dalloz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-26 21:31 UTC by Ville Skyttä
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.6.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 13:52:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes for keychain specfile and scripts (4.63 KB, patch)
2005-11-26 21:31 UTC, Ville Skyttä
no flags Details | Diff
Updated manpage patch (will also send upstream) (1.44 KB, patch)
2005-11-26 21:32 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2005-11-26 21:31:10 UTC
Bunch of issues here:  
  
1) I was finally bitten by the "keychain breaks scp" issue I had vaguely    
mentioned earlier:    
    
On a box with FE keychain installed, opt-in enable some user who has bash or    
csh as the shell and some SSH keys that require passphrases, and ensure his    
ssh-agent/keychain stuff is NOT active ("keychain --stop all").  Then, try to   
scp something from another box to that account: doesn't work, the _remote_ end    
starts prompting for passphrases.    
    
2) The opt-in stuff in ~/.keychainrc doesn't work as advertised because zsh    
treats the args differently from other shells (foo="foo bar"; echo $foo #    
results in one argument "foo bar" passed to echo, not "foo" and "bar").  
  
3) The opt-in mechanism seems to Just Work out of the box without any special  
tricks with zsh (maybe in >= 4.2.0-3), so README.Fedora should be updated.  
  
4) 2.6.1 is out.  
  
I took the liberty of fixing all of the above as well as other couple of  
cosmetic issues, patches attached.  Tested on FC4 with bash, pdksh, zsh and 
tcsh, and basic idea additionally with ash and FreeBSD's and Solaris' /bin/sh.  
Do you mind if I commit this for FC4 and later?  (I don't have a FC3 box to 
test with.)

Comment 1 Ville Skyttä 2005-11-26 21:31:11 UTC
Created attachment 121510 [details]
Fixes for keychain specfile and scripts

Comment 2 Ville Skyttä 2005-11-26 21:32:15 UTC
Created attachment 121511 [details]
Updated manpage patch (will also send upstream)

Comment 3 Alexander Dalloz 2005-12-01 10:58:24 UTC
Ville,

thanks for spotting 1) especially and the zsh related situation.

Please, feel free to update the FE package with current upstream version 2.6.1,
along with your patches. Reviewed those 2 report attachments and they look - as
usual work by you - fine.


Comment 4 Ville Skyttä 2005-12-01 13:52:25 UTC
Ok, 2.6.1-1.* submitted and built for FC-4 and devel, will be in the next push.
 Thanks.


Note You need to log in before you can comment on or make changes to this bug.