Bug 174264 - cannot interrupt or terminate yum gracefully
cannot interrupt or terminate yum gracefully
Status: CLOSED DUPLICATE of bug 139459
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-26 17:30 EST by Roland McGrath
Modified: 2014-01-21 17:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-26 17:32:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland McGrath 2005-11-26 17:30:20 EST
Description of problem:

Yum never responds well to being interrupted by ^C or killed by a SIGTERM.
It usually doesn't stop at all.  When downloading, it will abort one transfer
and then move on to trying the next mirror as if the user interruption had been
a network error.  It usually is suspendable with ^Z, and then killing it
gracefully never works either.  I have to kill -9 it every time.
This is a very poorly-behaved program.

Version-Release number of selected component (if applicable):
Every version I have ever seen.

How reproducible:
99.44%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rahul Sundaram 2005-11-26 17:32:30 EST
Thank you for the bug report. This particular bug has already been reported
into our bug tracking system, but please feel free to report any further
bugs you find.

*** This bug has been marked as a duplicate of 139459 ***

Note You need to log in before you can comment on or make changes to this bug.