Bug 174279 - Segfault while starting Xorg in AccessUsingXdmcp ()
Segfault while starting Xorg in AccessUsingXdmcp ()
Status: CLOSED DUPLICATE of bug 178986
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-11-27 02:39 EST by Adam Szalkowski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 05:15:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 5068 None None None Never
FreeDesktop.org 5218 None None None Never

  None (edit)
Description Adam Szalkowski 2005-11-27 02:39:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8) Gecko/20051118 Fedora/1.5-0.5.0.rc3 Firefox/1.5

Description of problem:
When starting Xorg I get a segfault. This is even before the config file is read.

Program received signal SIGSEGV, Segmentation fault.
0x000000000054e9d3 in AccessUsingXdmcp ()
(gdb) bt
#0  0x000000000054e9d3 in AccessUsingXdmcp ()
#1  0x000000000054f6d9 in DefineSelf ()
#2  0x00000000005509b2 in CreateWellKnownSockets ()
#3  0x0000000000432dc7 in main ()

Whereas I start the server with "-nolisten tcp", just as system-config-display does it, the server is starting fine.


Version-Release number of selected component (if applicable):
x11-server-Xorg-0.99.3-9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. just start Xorg
  

Additional info:
Comment 1 Adam Szalkowski 2006-01-04 03:12:49 EST
I have found the reason for this segfault:

There is an unitialized irda0 network device in my system which has no network
address and therefore Xorg tries to dereference a NULL pointer.

<quote>
This interface does not have an address. DefineSelf in the xorg source code
requires that network interfaces that are valid have a non-null address field.
This leads to a segfault because ConvertAddr attempts to dereference that pointer.
</quote>

This bug is described in https://bugs.freedesktop.org/show_bug.cgi?id=5068
and a solution is suggested in https://bugs.freedesktop.org/show_bug.cgi?id=5218
Please apply this patch to Xorg.
Comment 2 Mike A. Harris 2006-01-31 19:22:59 EST
Ah, thanks very much for the report, and upstream bug URLs also!  I believe
we've gotten other bug reports from people with similar hangs but slightly
different systems, which this is likely to resolve as well.

I'll update the report once I've had a chance to snag the patch and update
the packages.

Thanks again!
Comment 4 Mike A. Harris 2006-02-06 01:36:11 EST
I've added a patch which should fix this to xorg-x11-server-1.0.1-2

Please update to the new release and update the report with the status
of test results.

Thanks in advance.
Comment 5 Mike A. Harris 2006-02-07 05:15:32 EST

*** This bug has been marked as a duplicate of 178986 ***

Note You need to log in before you can comment on or make changes to this bug.