Bug 174281 - Too many other ports listed causes Configuration window load failure in KDE
Too many other ports listed causes Configuration window load failure in KDE
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-securitylevel (Show other bugs)
4
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-27 03:24 EST by William Ruth
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-02 13:51:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Ruth 2005-11-27 03:24:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
I noticed that when I enter too many ports into the Other ports field of the Security Level Configuration window(becuase I cannot enter a range, I tried to enter each individual port of that range) and then press ok, the next time I try to open the Security Level Configuration window it fails to open. When running system-config-securitylevel from the shell, I can get into a console version of this window. From this console version I see that the complete list of Other ports I supplied to the Security Level Configuration window was truncated prematurely. After removing all the ports I had entered before, and trying the Security Level Configuration window, it worked normally as before. Obviously the number of ports which can be entered in this field is finite, but a user should be able to still access the Security Level Configuration no matter what values are entered in this field.

Version-Release number of selected component (if applicable):
Version off stable FC4 install disks

How reproducible:
Always

Steps to Reproduce:
1.Enter 30 different Ports in the Other Ports field of the Security Level Configuration window
2.Press OK
3.Try to reopen the Security Level Configuration window through the menu by selecting: System Settings->Security Level
  

Actual Results:  Root Authentication was asked for.
After root authentication was given nothing happened
and Security Level Configuration window would never open.

Expected Results:  The Security Level Configuration window should open.

Additional info:

If too many values are entered into the Other ports field, then it would be nice to be informed of that and allowed to be able to correct it from the Security Level Configuration window.
Comment 1 Chris Lumens 2005-12-02 12:02:28 EST
The problem here is that each port you specify gets passed to lokkit as a
command line argument of the form "--port=<port>:<proto>".  So we're running
into the command line argument length limit, I believe.

The real fix will be range support in s-c-securitylevel (see bug 164187). 
However, there's probably something else worth investigating here as to why the
gui just doesn't even start.

Note You need to log in before you can comment on or make changes to this bug.