Bug 174300 - kernel hangs after wlan driver crash
kernel hangs after wlan driver crash
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-27 10:46 EST by Stefan Geuns
Modified: 2015-01-04 17:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 14:53:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Geuns 2005-11-27 10:46:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Sometimes the drivers of my wlan card crash (rt2500). But when this happens, the entire system hangs and responds to nothing.
I can't give any output of /var/log/messages since there are no usefull things there related to the crash.

I don't know if this is solvable, but it's highly anoying that whenever some driver doesn't want to work, everything hangs.

Version-Release number of selected component (if applicable):
2.6.12-1.1398_FC4

How reproducible:
Always

Steps to Reproduce:
1. Wait untill the wlan driver crashes
2.
3.
  

Actual Results:  Kernel hangs

Expected Results:  entry in dmesg that the wlan driver is no longer alive and I should be able to continue working without the need to reboot.

Additional info:
Comment 1 Dave Jones 2005-11-28 14:53:30 EST
please take up problems with out of tree drivers with their maintainers.
 
Comment 2 Stefan Geuns 2005-11-29 09:51:39 EST
The problem isn't that the driver crashes, the problem is that the kernel goes
with the driver and crashes too.

Note You need to log in before you can comment on or make changes to this bug.