Bug 1743017 - crio1.14 does not start
Summary: crio1.14 does not start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: cri-o
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1685454 1713395
TreeView+ depends on / blocked
 
Reported: 2019-08-18 15:15 UTC by Michael Gugino
Modified: 2020-03-06 02:41 UTC (History)
5 users (show)

Fixed In Version: cri-o-1.14-3020200226174119.a5b0195c cri-o-1.14-3120200226174119.f636be4b
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-06 02:25:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Michael Gugino 2019-08-18 15:15:44 UTC
Description of problem:
Attempting to start crio service (or directly from cli) results in fatal error.

Version-Release number of selected component (if applicable):
cri-o-2:1.14.9-1.module_f30+5132+c35a5687.x86_64

How reproducible:
100%

Steps to Reproduce:
1. dnf module enable cri-o:1.14
2. dnf install crio
3. /usr/bin/crio

Actual results:
FATA[2019-08-18 15:03:02.168704905Z] Invalid character(s) found in prerelease "module_f30"

Expected results:
crio starts normally

Additional info:
error is thrown by dependency: vendor/github.com/blang/semver/semver.go

cri-o-2:1.13.0-1.gite8a2525.module_f30+3068+5f412e7f.x86_64 works fine.

Comment 1 Jan Pazdziora 2019-10-18 10:14:14 UTC
Potential duplicate of bug 1754170.

Comment 2 Anders F Björklund 2019-11-03 11:29:34 UTC
This is caused by a %prep line in the packaging:

    sed -i 's/%{version}/%{version}-%{release}/' internal/version/version.go

It should probably just leave the version alone ?

Comment 3 Fedora Update System 2020-01-22 02:10:57 UTC
cri-o-1.16-3120191204144621.f636be4b has been pushed to the Fedora 31 Modular stable repository. If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2020-02-26 18:22:43 UTC
FEDORA-MODULAR-2020-c230523214 has been submitted as an update to Fedora 30 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2020-c230523214

Comment 5 Fedora Update System 2020-02-26 19:51:23 UTC
FEDORA-MODULAR-2020-36f52d4e8f has been submitted as an update to Fedora 31 Modular. https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2020-36f52d4e8f

Comment 6 Fedora Update System 2020-02-27 18:45:38 UTC
cri-o-1.14-3020200226174119.a5b0195c has been pushed to the Fedora 30 Modular testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2020-c230523214

Comment 7 Fedora Update System 2020-02-27 18:49:04 UTC
cri-o-1.14-3120200226174119.f636be4b has been pushed to the Fedora 31 Modular testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-MODULAR-2020-36f52d4e8f

Comment 8 Fedora Update System 2020-03-06 02:25:47 UTC
cri-o-1.14-3020200226174119.a5b0195c has been pushed to the Fedora 30 Modular stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2020-03-06 02:41:20 UTC
cri-o-1.14-3120200226174119.f636be4b has been pushed to the Fedora 31 Modular stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.