Bug 174308 - Screen Resolution table entries needs to be synched with resolutions in Display Settings table
Screen Resolution table entries needs to be synched with resolutions in Displ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-27 12:18 EST by Ewin Barnett
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-29 16:42:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ewin Barnett 2005-11-27 12:18:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
The settings tab of the Display Settings tool allows 1280x800.  The hardware tab of the Display Settings tool allows the selection of a Monitor Type of LCD panel 1280x800.  However, the resolution table in the Screen Resolution Preferences tool only allows 1027x768, 800x600 and 640x480.

These tables need to be reconciled or synchronized so an option that is allowed in one is not forbidden in another.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Set monitor type and resolution
2.Set resolution and number of colors
3.Try to set screen resolution
  

Actual Results:  User is presented with an incomplete list of permitted resolutions.

Expected Results:  User should have been presented with a list of all valid resolutions for the display and monitor selected.

Additional info:

It would be helpful that somewhere, maybe in the release notes, that the location of these tables is given and the sequence of their use in the configuration steps is listed so a user with a non-standard display can find where to poke his specific values.  The present setup is a closed box.
Comment 1 Robert Bertram 2006-01-30 21:22:50 EST
I see something very similar with a clean install of FC5 test 2. Firstboot allow
the setting of a 1920x1200 monitor but booting finds a resolution of 1600x1200.
Display settings shows 1920x1200 available but screen resolution preferences
does not. 

A custom modeline needs to be set. From memory this is a regression from FC4.
Comment 2 Ewin Barnett 2006-01-31 11:25:57 EST
On FC5t1, the Screen Resolution list only has entries for 800x600 and 640x480,
even though the Monitor is set to LCD 1280x800.  It would help if this table
came from a file that could be edited in case a resolution was needed that was
not normal.
Comment 3 Rahul Sundaram 2006-02-20 06:26:03 EST

These bugs are being closed since a large number of updates have been released
after the FC5 test1 and test2 releases. Kindly update your system by running yum
update as root user or try out the third and final test version of FC5 being
released in a short while and verify if the bugs are still present on the system
.Reopen or file new bug reports as appropriate after confirming the presence of
this issue. Thanks
Comment 4 Robert Bertram 2006-02-22 06:33:05 EST
I just tried FC5 Test 3 and the resolution was set fine this time. It looks good
to me.
Comment 5 Adam Jackson 2006-09-29 16:42:50 EDT
This should definitely be sorted as of system-config-display 1.0.45-1 or so,
which uses the RANDR mode list.  Please reopen if this is still an issue for you.

Note You need to log in before you can comment on or make changes to this bug.