Bug 174309 - clamav-milter functionality failures
clamav-milter functionality failures
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: clamav (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-27 12:28 EST by Tim Malnati
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-24 08:17:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Malnati 2005-11-27 12:28:09 EST
Description of problem:

clamav-milter: If a configuration file is declared, it does not appear to be
loading with clamav-milter.  Neither form of the command line option work (-c
FILE -or- --config-file=FILE).  It fails if either invoked directly from the
command line or started as a daemon.


Version-Release number of selected component (if applicable):

clamav-0.87.1-1.fc4
clamav-milter-0.87.1-1.fc4


How reproducible:  always


Steps to Reproduce:  see additional info section symptoms

  
Actual results:  functionality missing (see additional info section)


Expected results:  config file functionality


Additional info:  Symptoms:

* If a log file location is declared in the config file it is NOT created.  NO
log entries are produced even if the file is created manually and permissions
opened so that anyone can see and write to the file.

* If a pid file is declared in the config file it is NOT created.  Again,
permissions were changed to allow anyone to write to the declared directory.

* If a socket location is declared in the config file it is NOT used.  Attempts
to start clamav-milter without a socket location declared on the command line
will fail even though it is declared in the config file.

* If a socket location is declared on the command line, clamav-milter will start
as a daemon or from the command line.  Deliberately creating a mismatch to the
sendmail.cf socket location will cause clamav-milter to fail - as it should.

Unfortunately, with no logging available it is difficult to provide any
additional information for diagnosis.  Also, without logging it is impossible to
determine if the process actually does anything other than start.  Email that
has been processed does NOT have Xtag in header.

Contacted clamav.net for resolution.  Response: Perhaps you downloaded a ready
built RPM? In which case please either contact the package maintainer (they
don't contact us so we have no idea what they have done) or build a proper
version from source from www.clamav.net.
Comment 1 Enrico Scholz 2005-11-27 13:04:34 EST
Can not reproduce it. clamav-milter works here (nearly) out of the box. Just do an

| # yum install clamav-milter
| ... add the suggested line to sendmail.mc ...
| ... remove the 'Example' from /etc/clamd.d/milter.conf ...
| # chkconfig clamav-milter on
| ... restart system ...

The clamav-milter packages creates the /var/log/clamd.milter logfile with the
appropriate rights in the %post scriptlet.
Comment 2 Enrico Scholz 2005-12-24 08:17:38 EST
closing this bug because it works for me.
Comment 3 Tim Malnati 2005-12-24 10:19:34 EST
But did the config file do everything that it is intended to do?  It does not 
appear that you tested IAW my bug report.
Comment 4 Enrico Scholz 2005-12-24 10:55:20 EST
some parts of the config file (e.g. pidfile) are for interest only when milter
is used in external mode. The socketfile MUST be given on the cmdline.

The logfile works definitively (but is not very noisy).

I do not know what you mean with "does NOT have Xtag in header". Such an "Xtag"
header does not occur in clamav source.

Note You need to log in before you can comment on or make changes to this bug.