Bug 1743120 - package profile upload seems to be broken on RHEL7.7 [rhel-7.7.z]
Summary: package profile upload seems to be broken on RHEL7.7 [rhel-7.7.z]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.7
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: candlepin-bugs
QA Contact: Red Hat subscription-manager QE Team
URL:
Whiteboard:
: 1742822 (view as bug list)
Depends On: 1742208 1754859
Blocks: 1741577
TreeView+ depends on / blocked
 
Reported: 2019-08-19 06:56 UTC by RAD team bot copy to z-stream
Modified: 2019-09-24 08:59 UTC (History)
12 users (show)

Fixed In Version: subscription-manager-1.24.13-2.el7_7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1742208
Environment:
Last Closed: 2019-08-26 13:19:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2564 None None None 2019-08-26 13:19:57 UTC

Internal Links: 1741183 1809221

Description RAD team bot copy to z-stream 2019-08-19 06:56:09 UTC
This bug has been copied from bug #1742208 and has been proposed to be backported to 7.7 z-stream (EUS).

Comment 2 Chris Williams 2019-08-19 13:18:25 UTC
*** Bug 1742822 has been marked as a duplicate of this bug. ***

Comment 9 jcallaha 2019-08-20 19:26:43 UTC
Registered a 7.7 host to Satellite 6.6 Beta.
No errata listed for the host.
Updated the subscription-manager package.
No errata listed for the host.
Updated the python-syspurpose package.
Errata now showing up for the host.

Comment 10 jcallaha 2019-08-20 21:11:15 UTC
Verified in subscription-manager subscription-manager-1.24.13-2.el7_7.x86_64

I tested the above scenario against both Satellite 6.6 Beta and 6.5.2.

Both exhibited the same behavior with and without katello-host-tools installed.

Additionally, Satellite logs show the profiles being uploaded.

2019-08-20T17:08:20 [I|app|] Started PUT "/rhsm/consumers/df7a6295-61e9-44b8-854b-fcee970d229a/profiles" for 2620:52:0:10d2:225:90ff:fefd:f0a4 at 2019-08-20 17:08:20 -0400

Comment 12 errata-xmlrpc 2019-08-26 13:19:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2564


Note You need to log in before you can comment on or make changes to this bug.