Bug 1743279 - jenkins-2-plugins: Updates for latest openshift-sync, openshift-client and workflow-cps
Summary: jenkins-2-plugins: Updates for latest openshift-sync, openshift-client and wo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Jenkins
Version: 4.1.z
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Akram Ben Aissi
QA Contact: XiuJuan Wang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-19 14:18 UTC by Vibhav Bobade
Modified: 2020-05-04 11:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1740585
Environment:
Last Closed: 2020-05-04 11:13:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift jenkins pull 922 'None' closed Bug 1743279: Bump plugins versions 2020-04-23 07:24:47 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:13:35 UTC

Description Vibhav Bobade 2019-08-19 14:18:25 UTC
+++ This bug was initially created as a clone of Bug #1740585 +++

Description of problem:

jenkins-2-plugins: Updates for latest openshift-sync, openshift-client and workflow-cps

https://github.com/openshift/jenkins/pull/911

https://github.com/openshift/jenkins/pull/908

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from  on 2019-08-13 10:18:03 UTC ---

ART has been infored for the release via https://jira.coreos.com/browse/ART-882

--- Additional comment from  on 2019-08-13 10:31:48 UTC ---

Updated plugins

ace-editor:1.0.1
apache-httpcomponents-client-4-api:4.5.5-3.0
authentication-tokens:1.3
blueocean-autofavorite:1.2.2
blueocean-bitbucket-pipeline:1.10.2
blueocean-commons:1.10.2
blueocean-config:1.10.2
blueocean-core-js:1.10.2
blueocean-dashboard:1.10.2
blueocean-display-url:2.2.0
blueocean-events:1.10.2
blueocean-github-pipeline:1.10.2
blueocean-git-pipeline:1.10.2
blueocean-i18n:1.10.2
blueocean-jira:1.10.2
blueocean:1.10.2
blueocean-jwt:1.10.2
blueocean-personalization:1.10.2
blueocean-pipeline-api-impl:1.10.2
blueocean-pipeline-editor:1.10.2
blueocean-pipeline-scm-api:1.10.2
blueocean-rest-impl:1.10.2
blueocean-rest:1.10.2
blueocean-web:1.10.2
branch-api:2.0.20
cloudbees-bitbucket-branch-source:2.2.15
cloudbees-folder:6.6
conditional-buildstep:1.3.1
config-file-provider:3.5
credentials-binding:1.19
credentials:2.1.19
display-url-api:2.2.0
docker-commons:1.11
docker-workflow:1.14
durable-task:1.26
favorite:2.3.1
git-client:2.7.3
github-api:1.90
github-branch-source:2.3.6
github:1.29.2
github-organization-folder:1.6
git:3.9.3
git-server:1.7
handlebars:1.1
handy-uri-templates-2-api:2.1.6-1.0
htmlpublisher:1.16
jackson2-api:2.8.11.3
jenkins-design-language:1.10.2
jira:3.0.5
job-dsl:1.72
jquery-detached:1.2.1
jsch:0.1.54.1
junit:1.26.1
kubernetes-credentials:0.3.0
kubernetes:1.12.8
lockable-resources:2.5
mailer:1.21
mapdb-api:1.0.9.0
matrix-auth:2.2
matrix-project:1.14
mercurial:2.3
momentjs:1.1
openshift-client:1.0.32
openshift-login:1.0.19
openshift-sync:1.0.41
parameterized-trigger:2.35.2
pipeline-build-step:2.7
pipeline-github-lib:1.0
pipeline-graph-analysis:1.7
pipeline-input-step:2.8
pipeline-milestone-step:1.3.1
pipeline-model-api:1.3.4.1
pipeline-model-declarative-agent:1.1.1
pipeline-model-definition:1.3.4.1
pipeline-model-extensions:1.3.4.1
pipeline-rest-api:2.10
pipeline-stage-step:2.3
pipeline-stage-tags-metadata:1.3.4.1
pipeline-stage-view:2.10
pipeline-utility-steps:2.1.0
plain-credentials:1.4
pubsub-light:1.12
run-condition:0.10
scm-api:2.6.3
script-security:1.62
sse-gateway:1.16
ssh-credentials:1.14
structs:1.20
subversion:2.10.3
token-macro:2.8
variant:1.1
workflow-aggregator:2.6
workflow-api:2.36
workflow-basic-steps:2.11
workflow-cps-global-lib:2.15
workflow-cps:2.73
workflow-durable-task-step:2.26
workflow-job:2.29
workflow-multibranch:2.20
workflow-remote-loader:1.5
workflow-scm-step:2.7
workflow-step-api:2.20
workflow-support:3.3

Comment 5 Stephen Cuppett 2019-12-13 12:05:12 UTC
Targeting 4.4.0 for investigation on the current master branch. Given the state of the clone, this might actually already be resolved in 4.2+?

Comment 7 XiuJuan Wang 2020-03-13 06:43:44 UTC
Verified with jenkins image in 4.4.0-0.nightly-2020-03-11-212258 payload

sh-4.2$ cat /var/lib/jenkins/plugins/workflow-cps/META-INF/MANIFEST.MF | grep Implementation-Version
Implementation-Version: 2.73
sh-4.2$ cat /var/lib/jenkins/plugins/openshift-client/META-INF/MANIFEST.MF | grep Implementation-Version
Implementation-Version: 1.0.32
sh-4.2$ cat /var/lib/jenkins/plugins/openshift-sync/META-INF/MANIFEST.MF | grep Implementation-Version
Implementation-Version: 1.0.44

Comment 10 errata-xmlrpc 2020-05-04 11:13:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.