Bug 174333 - requirements are wrong for 64 bit platforms
requirements are wrong for 64 bit platforms
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nexuiz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-27 22:41 EST by Jeremy Katz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-30 05:34:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2005-11-27 22:41:55 EST
The hard coded requires on specific sonames won't work properly for 64bit
platforms.  You'd be better off just specifying packages if that's needed.

Also, is there a reason you went with the glx binary instead of SDL?
Comment 1 Adrian Reber 2005-11-28 01:55:57 EST
What do you think is better? This:

%ifarch x86_64 ppc64
Requires: libz.so.1()(64bit) libvorbis.so.0()(64bit) libvorbisfile.so.3()(64bit)
libjpeg.so.62()(64bit)
%else
Requires: libz.so.1 libvorbis.so.0 libvorbisfile.so.3 libjpeg.so.62
%endif

or just requiring the packages like this:

Requires: zlib libvorbis libjpeg

The reason for the glx binary instead of the SDL one was that it basically only
make sense to run nexuiz with GL and if there is hardware accelerated GL
available even SDL switches to GL. The was at least my understanding. Or there
some advantages of SDL?
Comment 2 Jeremy Katz 2005-11-28 09:49:23 EST
I'd just require the packages to be honest... it's not like they're packages
which have changed names very often.

And I actually got the SDL binary working with dri with no changes, but the glx
binary keeps falling back to indirect by default.  I need to poke at that some
more (and one a different machine as well, just to confirm it isn't some
goofiness with my laptop :)
Comment 3 Adrian Reber 2005-11-30 05:34:20 EST
Changes are in CVS and a build is requested. Let me know if this works.

Note You need to log in before you can comment on or make changes to this bug.