Bug 174367 - rc.sysinit multipath needs to be multipath.static
rc.sysinit multipath needs to be multipath.static
Status: CLOSED DUPLICATE of bug 168321
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-28 11:14 EST by Jeff Thomas
Modified: 2014-03-16 22:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 14:38:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for /etc/rc.d/rc.sysinit (2.67 KB, patch)
2005-11-28 11:17 EST, Jeff Thomas
no flags Details | Diff

  None (edit)
Description Jeff Thomas 2005-11-28 11:14:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
/etc/rc.d/rc.sysinit should use /sbin/multipath.static instead of /sbin/multipath to set up multipath devices at boot. The /sbin/multipath binary uses a shared library which is installed in /usr/lib, which will not be mounted yet if /usr is not the same filesystem as /root. This causes the multipath invocation to fail, which causes multipath devices to not get set up early enough for the filesystems to get mounted.

The same may be true of /sbin/dmraid although I have not tested this, there is a /sbin/dmraid.static so it may make sense to make this change as well.


Version-Release number of selected component (if applicable):
initscripts-7.93.20.EL-1

How reproducible:
Always

Steps to Reproduce:
1. Install with /usr a different filesystem than /
2. Set up a multipath device
3. Reboot, note loader error at boot, and multipath device missing from /dev/mapper

  

Additional info:
Comment 1 Jeff Thomas 2005-11-28 11:17:29 EST
Created attachment 121553 [details]
Patch for /etc/rc.d/rc.sysinit
Comment 2 Bill Nottingham 2005-11-28 14:38:24 EST

*** This bug has been marked as a duplicate of 168321 ***

Note You need to log in before you can comment on or make changes to this bug.