Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1743927 - Flaky tests: [Feature:ProjectAPI] TestProjectWatch should succeed [Suite:openshift/conformance/parallel]
Summary: Flaky tests: [Feature:ProjectAPI] TestProjectWatch should succeed [Suite:open...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 4.2.0
Assignee: Michal Fojtik
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-21 03:09 UTC by zhou ying
Modified: 2019-10-16 06:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:36:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift origin pull 23639 0 None None None 2019-08-21 11:06:07 UTC
Red Hat Product Errata RHBA-2019:2922 0 None None None 2019-10-16 06:37:07 UTC

Description zhou ying 2019-08-21 03:09:09 UTC
Description of problem:
https://prow.k8s.io/view/gcs/origin-ci-test/logs/canary-openshift-ocp-installer-e2e-azure-4.2/59

stderr:
fail [github.com/openshift/origin/test/extended/project/project.go:139]: unexpected event DELETED &v1.Project{TypeMeta:v1.TypeMeta{Kind:"", APIVersion:""}, ObjectMeta:v1.ObjectMeta{Name:"e2e-test-project-api-n4rtg", GenerateName:"", Namespace:"", SelfLink:"/apis/project.openshift.io/v1/projects/e2e-test-project-api-n4rtg", UID:"", ResourceVersion:"", Generation:0, CreationTimestamp:v1.Time{Time:time.Time{wall:0x0, ext:0, loc:(*time.Location)(nil)}}, DeletionTimestamp:(*v1.Time)(nil), DeletionGracePeriodSeconds:(*int64)(nil), Labels:map[string]string(nil), Annotations:map[string]string(nil), OwnerReferences:[]v1.OwnerReference(nil), Initializers:(*v1.Initializers)(nil), Finalizers:[]string(nil), ClusterName:"", ManagedFields:[]v1.ManagedFieldsEntry(nil)}, Spec:v1.ProjectSpec{Finalizers:[]v1.FinalizerName(nil)}, Status:v1.ProjectStatus{Phase:""}}



Version-Release number of selected component (if applicable):
redhat-openshift-release-informing#redhat-canary-openshift-ocp-installer-e2e-azure-4.2

How reproducible:
occasionally


Actual results:
Flaky tests:
[Feature:ProjectAPI] TestProjectWatch should succeed [Suite:openshift/conformance/parallel]

Comment 1 Brett Tofel 2019-08-28 15:39:22 UTC
Still happening, here's another view of the flake:

snipped from:

https://storage.cloud.google.com/origin-ci-test/logs/release-openshift-origin-installer-e2e-aws-4.2/3801/artifacts/e2e-aws/container-logs/test.log?_ga=2.264303564.-251980365.1567002723

<snip>
STEP: Destroying namespace "e2e-test-project-api-drcwk" for this suite.
Aug 28 13:34:37.299: INFO: Namespace e2e-test-project-api-drcwk was already deleted
Aug 28 13:34:37.301: INFO: Running AfterSuite actions on all nodes
Aug 28 13:34:37.301: INFO: Running AfterSuite actions on node 1
fail [github.com/openshift/origin/test/extended/project/project.go:139]: unexpected event DELETED &v1.Project{TypeMeta:v1.TypeMeta{Kind:"", APIVersion:""}, ObjectMeta:v1.ObjectMeta{Name:"e2e-test-project-api-drcwk", GenerateName:"", Namespace:"", SelfLink:"/apis/project.openshift.io/v1/projects/e2e-test-project-api-drcwk", UID:"", ResourceVersion:"", Generation:0, CreationTimestamp:v1.Time{Time:time.Time{wall:0x0, ext:0, loc:(*time.Location)(nil)}}, DeletionTimestamp:(*v1.Time)(nil), DeletionGracePeriodSeconds:(*int64)(nil), Labels:map[string]string(nil), Annotations:map[string]string(nil), OwnerReferences:[]v1.OwnerReference(nil), Initializers:(*v1.Initializers)(nil), Finalizers:[]string(nil), ClusterName:"", ManagedFields:[]v1.ManagedFieldsEntry(nil)}, Spec:v1.ProjectSpec{Finalizers:[]v1.FinalizerName(nil)}, Status:v1.ProjectStatus{Phase:""}}

Aug 28 13:34:32.848 W persistentvolume/pvc-7ce9ba29-c998-11e9-9c41-12834d857574 Error deleting EBS volume "vol-0e45c0c6cece5327e" since volume is currently attached to "i-0a0ae38231d67e94a"

failed: (47s) 2019-08-28T13:34:37 "[Feature:ProjectAPI]  TestProjectWatch should succeed [Suite:openshift/conformance/parallel]"
</snip>

Comment 2 Michal Fojtik 2019-08-29 10:51:50 UTC
https://github.com/openshift/origin/pull/23639 is in merge queue, should be fixed today.

Comment 5 errata-xmlrpc 2019-10-16 06:36:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.