Bug 1744073 - dnf repoquery --querytags doesn't work
Summary: dnf repoquery --querytags doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: dnf
Version: 8.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.0
Assignee: Marek Blaha
QA Contact: Jan Blazek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-08-21 09:27 UTC by Karel Srot
Modified: 2020-04-28 16:49 UTC (History)
4 users (show)

Fixed In Version: dnf-4.2.11-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 16:48:04 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1823 None None None 2020-04-28 16:49:03 UTC

Description Karel Srot 2019-08-21 09:27:14 UTC
Description of problem:

dnf-4.2.7-4.el8.noarch

# dnf repoquery --querytags
Error: Sack was not initialized

Expected output:

Available query-tags: use --queryformat ".. %{tag} .."

name, arch, epoch, version, release, reponame (repoid), evr,
debug_name, source_name, source_debug_name,
installtime, buildtime, size, downloadsize, installsize,
provides, requires, obsoletes, conflicts, sourcerpm,
description, summary, license, url

Should be already fixed upstream.

Comment 1 Marek Blaha 2019-08-26 11:42:14 UTC
Fixed in upstream by commits 5f5a95afb598038e6b5ed39131e0e089352a441a and c358daa476a4d7add92f4cbd2116949d278cfd81.

Comment 2 Pavla Kratochvilova 2019-08-26 11:59:47 UTC
Thank you, Marek. I'll assign you, since you are the author of the commits.

Links to the commits:
https://github.com/rpm-software-management/dnf/commit/5f5a95afb598038e6b5ed39131e0e089352a441a
https://github.com/rpm-software-management/dnf/commit/c358daa476a4d7add92f4cbd2116949d278cfd81

Comment 3 Karel Srot 2019-11-08 11:01:39 UTC
This is a regression, it is working on RHEL-8.0
# rpm -q dnf dnf-plugins-core
dnf-4.0.9.2-5.el8.noarch
dnf-plugins-core-4.0.2.2-3.el8.noarch

Comment 8 errata-xmlrpc 2020-04-28 16:48:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1823


Note You need to log in before you can comment on or make changes to this bug.