Bug 174411 - Update from clean fc4 to devel tree not possible because of conflict
Update from clean fc4 to devel tree not possible because of conflict
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2005-11-28 15:19 EST by Christian Nolte
Modified: 2014-03-16 22:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-11-28 15:24:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Christian Nolte 2005-11-28 15:19:57 EST
Description of problem:
After installing a clean fc4 distribution and updating the 2.6.11 kernel to
2.6.14, the yum-update to the current fedora-devel/fedora-extras-devel fails
because of a reported conflict: kernel < 2.6.12.

Version-Release number of selected component (if applicable):

How reproducible:
Install a clean fc4, update the kernel, activate
fedora-devel/fedora-extras-devel repos, deactivate fedora repo, issue a "yum update"

Steps to Reproduce:
1. Install fc4
2. Update kernel: yum install kernel
3. Activate the mentioned repos
4. yum update fails with conflict: kernel < 2.6.12
Actual results:
The update to the devel-repo cannot be done

Expected results:
The update should run smoothly...

Additional info:
This problem could be solved by removing the kernel-entry in line 20 of the
kudzu.spec file:

Conflicts: mkinitrd < 4.0, kernel < 2.6.12

And adding the kernel dependency to a Requires dependency:

Requires: kernel > 2.6.12

A rather dirty workaround is to manually do 'rpm -ev kernel-2.6.11-1-1369_FC4'
to remove the old kernel after the new one is installed.

Another thing is, that the same problem occurs during the update with the
current initscripts-8.17-1 package.
Comment 1 Bill Nottingham 2005-11-28 15:24:59 EST
Neither of them works with prior kernels. Since a Requires: allows them to be
booted with an old kernel, a Conflict: is more appropriate.

Note You need to log in before you can comment on or make changes to this bug.